Jump to content
  • 0

Optifine kann nicht installiert werden


fritzifu
 Share

Question

Recommended Posts

  • 3

Hi,

ok, dann machen wir mal einen einfachen Test.

Erstmal stell sicher, das du die aktuelle Java Version 8 Update 60 als 64bit Version installiert hast.

Weiterhin lege die Optifine Datei (OptiFine_1.8.7_HD_U_D6.jar) einfach auf deinen Desktop.

Wenn das der Fall ist, drückst du <Win-Taste> + <R>, es geht das "Ausführen" Fenster auf.

Hier gehst du auf "Durchsuchen", Nun Gehst du auf Laufwerk "C:", dann auf "Programme". Hier sollte ein Verzeichnis "Java" vorhanden sein.

In diesem muss nun ein Ordner "jre1.8.0_60" existieren, hier wieder doppelklick und weiter mit "bin" und dann wählst du die "java.exe" aus.

Im Ausführen Fenster sollte nun also stehen:

"C:\Program Files\Java\jre1.8.0_60\bin\java.exe"

Füge nun hinter diesen Text ein Leerzeichen gefolgt von "-jar" gefolgt von einem Leerzeichen und dann folgendes:

%homepath%\Desktop\OptiFine_1.8.7_HD_U_D6.jar

Es sollte nun also so aussehen:

"C:\Program Files\Java\jre1.8.0_60\bin\java.exe" -jar %homepath%\Desktop\OptiFine_1.8.7_HD_U_D6.jar

Dann einfach mit "OK" bestätigen. Was passiert nun?

-Yuki

  • Thanks 2
Link to comment
Share on other sites

  • 0

Ich habe Java schon x-mal neu installiert und natürlich auch den pc neu gestartet, 64-bit version, 32-bit version uind auch die optifine-Datei neu installiert, alles schon gemacht, aber trotzdem danke! Hat jemand noch einen anderen Vorschlag?

Link to comment
Share on other sites

  • 0

Danke! Hat mir sehr geholfen!

Hab alles eigegeben und dann hat es funktioniert, d.h. es hat ganz normal den Optifine-Installer gestartet. Kann jetzt endlich wieder mit optifine spielen. Muss ich das jetzt eig. immer über das Ausführen-Fenster machen wenn ich Java-Dateien öffnen will oder gibt es da noch was anderes, womit ich das eigentliche Problem, also das Error-Fenster beheben kann?

Edited by fritzifu
Link to comment
Share on other sites

  • 0

Hi,

das Problem ist, das du noch eine andere Java Installation auf dem Rechner hast, mit welcher der Optifine Installer nicht klar kam.

Es kommt einfach immer auf die Java Anwendung an, mit welcher Java Version diese kompatibel ist, daher ist es durchaus möglich, dass andere Java Anwendungen problemlos laufen.

An sich müsstest du halt schauen, was das noch für eine andere Version ist und diese halt entfernen, so das ebem wirklich nur auf die neue / aktuelle Version zurückgegriffen wird.

-Yuki

Link to comment
Share on other sites

  • 0

Hallo Yuki ich hab alles beachtet was du geschrieben hast auch die neue optifine version und die neue java version runter geladen aber wenn ich dann auf OK drück öffnet sich nur kurz ein weißes fenster und schließt sich dann wieder.

Kannst du mir helfen?

ImFroZzeN

Link to comment
Share on other sites

  • 0

Hallo ich habe das selbe Problem und habe lange nach einer Lösung gesucht. Es ist schwer antworten auf das Problem zu finden den die Methode von oben hat nicht Funktioniert =( wie kann man machen das man die alte java Version entfernt?

Link to comment
Share on other sites

  • 0

Versuchs mal mit Minecraft Forge


Minecraft Forge Mod Loader

Unter W 7

%appdata% im Suchfeld eingeben. Dann sollte sich ein Fenster öffnen wo du .Minecraft stehen siehst.

dort die Jar.bin löschen dann lädt sich Minecraft neu herunter ohne Maps zu löschen oder Texturepacks.

Die Alte Javaversion kannst du unter Computer und dann Programme ändern oder Deinstallieren Löschen.

 

 

 

Edited by lordargon766
Link to comment
Share on other sites

  • 0
Am 22.8.2015, 16:50:58 , Yuki sagte:

Hi,

 

welche Version von Java hast du installiert?

Schau bitte nach, das du die aktuellste Version hast: Version 8 Update 60.

 

Wenn nicht, deinstalliere bitte alle vorhandenen Versionen und installiere die aktuelle.

 

-Yuki

 

Link to comment
Share on other sites

  • 0

Hallo!

Ich weiß, dieses Thema ist schon etwas älter, aber ich habe bisher das Problem nicht behoben bekommen. Jetzt ist mir aufgefallen, dass wenn ich auf eine .jar-Datei rechtsklicke und dann auf "Öffnen mit..." gehe, habe ich da zwei Vorschläge: Der eine ist "Java Platform SE binary" und der andere ist "Java(TM) Platform SE binary".

Wenn ich auf die Option ohne (TM) klicke, steht im Bestätigungsfenster Java Version 8 Update 40 und die Fehlermeldung (s.o.) kommt und wenn ich mit (TM) klicke, steht da Version 8 Update 66 und Optifine installiert sich ganz normal. Jetzt wollte ich natürlich das Update 40 Deinstallieren, aber weder in Den Ordnern "Programme" oder "Programme (x86)" ist eine andere Version als Update 66 und auch im "Programm Deinstallieren"-Fenster findet sich nur eine Version, nämlich Version 8 Update 66.

Wo finde ich also Version 8 Update 40 um es zu deinstallieren?

fritzifu

Edited by fritzifu
Link to comment
Share on other sites

  • 0

Hi,

Nein, hat leider nicht geklappt. Habs aber jetzt anderst gelöst bekommen: Habe den Dateipfad von Java 8 Update 40 geöffnet, und der lag irgendwo in einem Unterordner im Downloadordner. Frag mich nicht, wie der da hingekommen ist, aber habe ihn gelöscht und jetzt ist auch die Option weg, alles funktioniert prima!

Vielen Dank nochmal für die tolle Hilfe!

fritzifu

Link to comment
Share on other sites

  • 0
Am 25.9.2015 um 22:18 schrieb Yuki:

Hi,

 

ok, dann machen wir mal einen einfachen Test.

Erstmal stell sicher, das du die aktuelle Java Version 8 Update 60 als 64bit Version installiert hast.

Weiterhin lege die Optifine Datei (OptiFine_1.8.7_HD_U_D6.jar) einfach auf deinen Desktop.

 

Wenn das der Fall ist, drückst du <Win-Taste> + <R>, es geht das "Ausführen" Fenster auf.

 

Hier gehst du auf "Durchsuchen", Nun Gehst du auf Laufwerk "C:", dann auf "Programme". Hier sollte ein Verzeichnis "Java" vorhanden sein.

In diesem muss nun ein Ordner "jre1.8.0_60" existieren, hier wieder doppelklick und weiter mit "bin" und dann wählst du die "java.exe" aus.

 

Im Ausführen Fenster sollte nun also stehen:

"C:\Program Files\Java\jre1.8.0_60\bin\java.exe"

 

Füge nun hinter diesen Text ein Leerzeichen gefolgt von "-jar" gefolgt von einem Leerzeichen und dann folgendes:

%homepath%\Desktop\OptiFine_1.8.7_HD_U_D6.jar

 

Es sollte nun also so aussehen:

"C:\Program Files\Java\jre1.8.0_60\bin\java.exe" -jar %homepath%\Desktop\OptiFine_1.8.7_HD_U_D6.jar

 

Dann einfach mit "OK" bestätigen. Was passiert nun?

 

-Yuki

Hi, es hat alles geklappt bis auf das es bei mir keine java.exe gibt und ich habe einfach keine Ahnung

Wenn ich Optifine mit Java(TM) Platform SE binary öffne geht nur die Konsole kurz auf mit einer Fehlermeldung sonst passiert nichts

-mit Jonas

Link to comment
Share on other sites

  • 0

Hi,

schau dir mal bitte folgenden Beitrag von mir an: https://minecraftforum.de/topic/10418-tips-für-probleme-beim-installieren-von-optifine/

Da ist das ganze nochmal etwas ausführlicher beschrieben.

Ganz davon ab muss es die "java.exe" geben denn der Punkt "Java(TM) Platform SE binary" verweist auf diese. Eventuell musst du nochmal wegen dem Pfad schauen zwischen 32-bit und 64-bit Installation. Dies ist aber auch in dem Verlinkten Beitrag hier mit angegeben.

Im Notfall kannst du auch die "javaw.exe" nehmen, aber diese bringt uns bei einem Fehler keine Meldung auf der Konsole, wenn einer auftritt.

 

-Yuki

Link to comment
Share on other sites

  • 0
Am 25.9.2015 um 22:18 schrieb Yuki:

Hi,

 

ok, dann machen wir mal einen einfachen Test.

Erstmal stell sicher, das du die aktuelle Java Version 8 Update 60 als 64bit Version installiert hast.

Weiterhin lege die Optifine Datei (OptiFine_1.8.7_HD_U_D6.jar) einfach auf deinen Desktop.

 

Wenn das der Fall ist, drückst du <Win-Taste> + <R>, es geht das "Ausführen" Fenster auf.

 

Hier gehst du auf "Durchsuchen", Nun Gehst du auf Laufwerk "C:", dann auf "Programme". Hier sollte ein Verzeichnis "Java" vorhanden sein.

In diesem muss nun ein Ordner "jre1.8.0_60" existieren, hier wieder doppelklick und weiter mit "bin" und dann wählst du die "java.exe" aus.

 

Im Ausführen Fenster sollte nun also stehen:

"C:\Program Files\Java\jre1.8.0_60\bin\java.exe"

 

Füge nun hinter diesen Text ein Leerzeichen gefolgt von "-jar" gefolgt von einem Leerzeichen und dann folgendes:

%homepath%\Desktop\OptiFine_1.8.7_HD_U_D6.jar

 

Es sollte nun also so aussehen:

"C:\Program Files\Java\jre1.8.0_60\bin\java.exe" -jar %homepath%\Desktop\OptiFine_1.8.7_HD_U_D6.jar

 

Dann einfach mit "OK" bestätigen. Was passiert nun?

 

-Yuki

Ich hab alles so gemacht wie du gesagt hast. Mit dem Unterscheid, dass ich ein anderes optfine verwende. Bei mir aber passiert gar nichts. Ich hab aber auch ein Problem mit minecraft. Es startet nur noch, wenn ich das alte Minecraft fenster verwenden. Könnte es eventuell daran liegen? 

 

danke im vorraus

 

-Fox

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...
B