Jump to content

Hast du schon das Minecraftforum.de-Gütesiegel gesehen? Hier kommst du dorthin!

  • 0
Yuki

Tips für Probleme beim Installieren von Optifine

Question

Hi,

da in letzter Zeit viele Probleme beim installieren von Optifine haben und ich auch schon mehr per PM angeschrieben wurde wir das da gemacht haben, werde ich das nun einfach mal alles in einem Beitrag zusammenfassen:

 

1. Stell bitte sicher, das du die aktuelle Java Version installiert hast.

Hier nochmal der Link zum Download: Java-Downloads für alle Betriebssysteme

Wenn du ein 64-bit Windows hast die "Windows Offline (64-Bit)" ansonsten die "Windows Offline".

2. Schau bitte auch nach, dass du nicht noch eine ältere Version von Java installiert hast. Am einfachsten über "Systemsteuerung" - "Programme und Features" und hier die Liste nach Name sortieren und schauen wie oft Java vorkommt. Eventuell ältere Versionen deinstallieren.

3. Lade dir deine gewünschte Version von Optifine herunter. Für die Anleitung hier gehe ich von der aktuellen (zur Zeit er Erstellung der Anleitung) Version 1.8.8_HD_U_G7 aus.

Hier nochmal der Link zum Download: OptiFine Downloads

4. Lege die Datei "OptiFine_1.8.8_HD_U_G7.jar" bitte direkt auf deinen Desktop.

5. Drücke die <Windows-Taste>+R und es sollte ein kleines Fenster unten links aufgehen "Ausführen". Hier gehst du auf den Button "Durchsuchen". Nun klickst du links auf "Dieser PC" und dann auf dein Laufwerk "... (C:)". Hier ist nun je nach Java, welches du installiert hast der Ordner auszuwählen:

Java 32-bit: "Programme (x86)"

Java 64-bit: "Programme"

Weiter gehst du in den Ordner "Java". Hier müsste es nun einen Ordner geben, welcher der aktuellen von dir installierten Version entspricht, z.B. "jre1.8.0_66". Hier wieder Doppelklick und weiter in "bin". Nun suchst du die Datei "java.exe", klickst diese einmal an und gehst unten auf "Öffnen". Nun sollte in dem "Ausführen" Fenster ein Pfad stehen, der etwa so aussieht:

"C:\Program Files\Java\jre1.8.0_66\bin\java.exe"

Füge nun hinter diesen Text ein Leerzeichen gefolgt von:

-jar %homepath%\Desktop\OptiFine_1.8.8_HD_U_G7.jar

Es sollte nun also in etwa so aussehen:

"C:\Program Files\Java\jre1.8.0_66\bin\java.exe" -jar %homepath%\Desktop\OptiFine_1.8.8_HD_U_G7.jar

Diesen Befehl kopierst du nun komplett. (STRG+A und STRG+C - Nicht auf OK klicken.)

6. Wenn du den Befehl kopierst hast, lösche diesen aus dem Fenster, so dass du wieder eine leere Eingabebox hast und gibst dort als Befehl

cmd

ein und bestätigst diesen mit OK.

7. Es geht ein kleines schwarzes Konsolenfenster auf. Hier machst du oben auf die Titelleiste einen Rechtsklick und gehst auf "Bearbeiten" - "Einfügen". Der lange Befehl, welchen du vorher kopiert hast sollte nun in dem Fenster stehen. Nun einfach <ENTER> drücken und schauen, was als Bestätigung angezeigt wird.

8. Beskommst du als Rückmeldung ein "Zugriff verweigert", dann gehe bitte die weiteren Punkte durch, ansonsten erstelle bitte einen Screenshot von dem Fenster und hänge es an deinen Beitrag an. Dazu hast du hier in Forum unter der Eingabebox den Punkt "Wähle die Dateien hier aus..."

 

9. Solltest du "Zugriff verweigert" bekommen haben, dann können wir etwas probieren:

Ich nehme an, es ist ein USB Stick oder eine externe Festplatte vorhanden?

Stecke diese(n) mal bitte an und schau, welcher Laufwerksbuchstabe das ist. Kopiere als erstes die Optifine-Datei von deinem Desktop direkt auf den Stick / die Festplatte.

Dann änderst du den Befehl entsprechend ab, so das er zu dem neuen Pfad passt, also in etwa so aussieht:

"C:\Program Files\Java\jre1.8.0_66\bin\java.exe" -jar E:\OptiFine_1.8.8_HD_U_G7.jar

Wobei hier E: der Stick / die Festplatte wäre, was du entsprechend anpassen müsstest.

Den Befehl wieder kopieren und in das Konsolenfenster einfügen und mit <ENTER> ausführen. Im Idealfall sollte der Optifine-Installer starten. Wenn nicht, dann bitte einen Screenshot der Meldung an einen Beitrag anhängen.

 

-Yuki

  • Thanks 1

Share this post


Link to post
Share on other sites

42 answers to this question

Recommended Posts

  • 0

C:\Users\Lukas Wanzenböck>"C:\Program Files\Java\jre1.8.0_71\bin\java.exe" -jar %homepath%\Desktop\OptiFine_1.8.9_HD_U_H2.jar
Error: Unable to access jarfile \Users\Lukas

Ehhh...

Share this post


Link to post
Share on other sites
  • 0

Hi,

er mag das Leerzeichen im Benutzername nicht. Siehst du daran, das inm der Fehlermeldung der Pfad nach "...Lukas" aufhört. Das "ö" als Sonderzeichen macht manchmal aber auch Probleme. Daher:

Versuche es direkt mit Punkt 9, da solltes es auf jedenfall funktionieren.

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

OK. Jetzt kommt "-Jar requires jar file specification"

*Darunter ne lange Wurst was glaub ich alle Java befehle sind*

Pfad konnte nicht gefunden werden

 

 

Share this post


Link to post
Share on other sites
  • 0

Hi,

dann stimmt der Pfad zu deiner Optifine Datei nicht, also das was hinter "-jar" steht erkennt er nicht als gültige Java-Datei.

Prüfe nochmal, das der Pfad auch stimmt und du nicht ausversehen einen Schreibfehler drin hast.

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

Ok, Noch mal ganz von vorn.

Ich hab in cmd "C:\Program Files\Java\jre1.8.0_71\bin\java.exe" -jar %homepath%\Desktop\OptiFine_1.8.9_HD_U_H2.jar eingegeben. Dort war das Problem, das nur Lukas realisiert wurde.

vor 4 Stunden, Yuki sagte:

er mag das Leerzeichen im Benutzername nicht. Siehst du daran, das inm der Fehlermeldung der Pfad nach "...Lukas" aufhört. Das "ö" als Sonderzeichen macht manchmal aber auch Probleme.

Das Problem ist, das cmd gleich Standartmäßig C:\Users\Lukas Wanzenböck> hinschreibt, aber dann nur Lukas hernimmt. Mein Microsoft-Konto kann ich natürlich auch nicht so hinstellen, das ich nur einen Namen habe.

Darum würde Punkt 9 auch nicht funktionieren weil ja cmd gleich C:\Users\Lukas Wanzenböck> hinschreibt.

Share this post


Link to post
Share on other sites
  • 0

Hi,

hier ist ein kleines Missverständnis deinerseits. ;)

Das was dort im cmd steht kannst du ignorieren, denn du gibst bei Punkt 9 einen festen Pfad an, der außerhalb deines Profils liegt und zwar auf einem Stick / einer Festplatte.

Das Problem tritt dann auf, wenn du %homepath% benutzt, denn das %homepath% ist eine Abkürzung für deinen Profilpfad, wo wir das Problem mit dem Leerzeichen haben.

Wenn du nun aber einen USB-Stick oder eine externe Festplatte nutzt, gibst du ja wie in Punkt 9 beschrieben einen Pfad direkt zu dieser an, also z.B.

-jar E:\Optifine.jar

und nicht wie es mit %homepath% wäre

-jar C:\Users\Dein Name\Desktop\Optifine.jar

Klar könnte man es hier jetzt auch mit %homepath% zum laufen bekommen, indem man alles in Anführungszeichen schreibt, also

-jar "%homepath%\Desktop\Optifine.jar"

nur haben wir bei dir noch das Problem mit dem Sonderzeichen "ö" und daher haben wir hier nur die Möglichkeit es extern zu machen.

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

ENDLICH!!!!!!!!!!!!!!!!!!!!

 

Andere Frage ist geht das jetzt mir jedem Mod nur druch ersetzen der datei also anstatt der optifine Datei dann zb beim laby Mod die Laby Mod datei ?

NÄCHSTE FRAGE:

Wie instaliert man einen Plug in auf ein server ? habe einen Nitrado server und will einen ,,varo´´ plug in instalieren habe jedoch keine idee wie das funktioniert und es gibt (kein für mich ) sinnvolles tutorial . ADaher du sehr Kompetent Aussiehst hast du ne ahnung ?:)

Edited by deejay63

Share this post


Link to post
Share on other sites
  • 0

Hi,

1. Es kommt sehr auf den Mod an. Wenn es einen eigenen Installer hat, dann kannst / musst du das so machen, aber normalerweise werden die Mods ja nicht direkt in eine Vanilla Version eingebunden sondern über Forge oder Bukkit / Spigot und in dem Falle musst du die Dateie(n) nur in den entsprechenden Mods oder Plugins Ordner kopieren.

2. Hier sind wir auch schon bei deiner 2. Frage, auch wenn es mir lieber gewesen wäre, wenn du es in einen separaten Thread gemacht hättest, da es nicht wirklich hier in den Optifine Thread gehört. Soweit ich weiß, brauchst du für Varo einen Bukkit / Spigot Server, also kein Vanilla Minecraft und auch kein Forge. Du musst dann einfach nur das Varo Plugin in den Plugins-Ordner deines Server kopieren und diesen neu starten. Du brauchst also einfach nur bei Nitrado einen Spigot-Server ( Spigot – Nitradopedia ).

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

ah es hat doch geklappt hatte nämlich aus etlichen versuchen davor die Meta-Inf Datei gelöscht und musste mir es einfach neu installieren trotzdem danke :D

Share this post


Link to post
Share on other sites
  • 0

Mittlerweile gibt es schon für alles einen Installer, egal ob Java (.jar) oder als C, etc (.exe)... und dann gibt es Leute die es nicht hinbekommen? 

Wie Ich angefangen hab, musste man sich den Script von Mods beschaffen auf Seiten die keine Clickbates waren und man sich Packete über Github downgeloadet hat...

 

 

Share this post


Link to post
Share on other sites
  • 0
Am 5.12.2015 um 23:16 schrieb Yuki:

1. Stell bitte sicher, das du die aktuelle Java Version installiert hast.

Hier nochmal der Link zum Download: Java-Downloads für alle Betriebssysteme

 

Man sollte zuerst die Konsole öffnen, und die korrekte Installation von Java und deren Version prüfen, indem man ein Betriebssystem mitgeliefertes Program startet.

Start -> Suche -> cmd

In dem Dos Fenster schreibt ihr nun: java -version

Wenn alles richtig läuft sollte da Java mit der Version "1.8.0_50" bis|oder "1.8.0_71" stehen

Share this post


Link to post
Share on other sites
  • 0

Hey ich habe das Problem das ich keine Java.exe datei unter Programme finde...

 

so jzt habe ich es einfach bei windows taste und r die altenverläufe nachgeschaut und alle nach anleitung gemacht .. jzt zeigt er mir an das er jar nicht finden konnte :( pls hilfe gerne auch per team viewer

 

 

Edited by deejay63

Share this post


Link to post
Share on other sites
  • 0

Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\leon2>"C:\Program Files\Java\jre1.8.0_66\bin\java.exe" -jar %homepath%\Desktop\OptiFine_1.8.8_HD_U_G7.jar
Das System kann den angegebenen Pfad nicht finden.

C:\Users\leon2>

was soll ich tuuun???

Share this post


Link to post
Share on other sites
  • 0

Hi,

@deejay63 wenn du das Java nicht findest, achte bitte darauf, ob 32-bit oder 64-bit, weil sich da der Pfad ändert (siehe Punkt 5). Auch solltest du den Pfad aus meiner Anleitung nicht 1 zu 1 übernehmen, da es mittlerweile schon mehrere neue Versionen von Java gab und die _66 nicht mehr aktuell ist sondern durch deine installierte Version, also z.B. _91 ersetzt werden müsste.

Wenn er die .jar-Datei nicht findet, dann prüfe bitte, ob du es richtig geschrieben hast und die Datei auch wirklich dort so liegt. Ansonsten bitte Punkt 9 testen, da es manchmal mit dem Pfad zum Desktop Probleme gibt.

@leon27022002 Wie schon da steht, hast du einen Pfad zu einer Datei angegeben, welcher nicht existiert. Prüfe bitte nochmal, ob die Pfade auch stimmen und die Dateien da liegen. Ansonsten bitte Punkt 9 versuchen, da es manchmal mit dem Pfad zum Desktop Probleme gibt.

 

-Yuki

Edited by Yuki

Share this post


Link to post
Share on other sites
  • 0

Hier bitte:

 

2016-07-24 21_58_06-C__windows_system32_cmd.exe.png

und Ps:

Vllt wäre es nett wenn du ein Video machst wo du alle schritte durchnimmst, den ich hab ein bisschen gebraucht bis ich gecheckt hab was ich machen soll. xP

Edited by BlauesBIld

Share this post


Link to post
Share on other sites
  • 0

Hi,

prüfe bitte, ob der Pfad korrekt ist und ob die Datei auch wirklich dort liegt und genau so heißt.

Das "Unable to access jarfile" kommt normalerweise dann, wenn er die Datei nicht finden kann, oder diese defekt ist.

Also wenn der Pfad korrekt sein sollte, dann versuche bitte nochmal einen neuen Download der Datei, nicht das einfach hier etwas schief gegangen ist.

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

Hats sich geklärt wollte Labymod installieren hab aber Optifine hingeschrieben xP

 

So, Frage nummero 2: Wenn ich Labymod installieren will, und ich Optifine mit ausgewählt habe, funktionierts wieder nicht. Lösung?

 

Edited by BlauesBIld

Share this post


Link to post
Share on other sites
  • 0

Da steht dann so etwas wie "Problems with Installation of Optifine, Labymod skips this Installation".

 

Also wird es einfach übersprungen.

Edited by BlauesBIld

Share this post


Link to post
Share on other sites
  • 0

Hi Yuki

Ich habe deine Tipps durchgelesen und auch zur halbe gemacht. Denoch steht bei mir keine Datei die java.exe / javaw.exe heisst. Ich Suche seid etwa 1 Monat nach einer Lösung. Deine gefällt mir bis jetzt am besten. Ich habe java x mal deinstalliert und wieder Installiert aber es hilft nichts. Auch schon 32 Bit installiert und auch 64 Bit. Habe gerade die 64 Bit Version. Hoffe du kannst mir irgendwie Helfen. Maaann ich will mit Optifine spielen und mit laby mod...:BLAZER:

Lg Chilli!

 

Share this post


Link to post
Share on other sites
  • 0

Hi,

Windows blendet Dateiendungen für bekannte Dateitypen standardmäßig aus, also wenn du das nicht umgestellt hast, wird dir das ".exe" nicht angezeigt, sondern nur der Name an sich "java" oder "javaw". Die Dateien haben ein weißes Symbol mit einer Kaffeetasse drauf. Aber aufpassen, da gibt es mehrere davon. (Wenn du die Ansicht auf "Details" einstellst, steht in der Spalte Typ "Anwendung".)

Ansonsten findest du den Pfad aber schon, also du kommst bis in den "bin"-Ordner oder bleibst du schon eher hängen?

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

Bei mir kommt die Nachicht :

C:\Users\Finn>"C:\Program Files\Java\jre1.8.0_111\bin\java.exe" -jar%homepath%/Desktop/Optifine_1.8.9_HD_U_G7.jar
Unrecognized option: -jar\Users\Finn/Desktop/Optifine_1.8.9_HD_U_G7.jar
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

C:\Users\Finn>
C:\Users\Finn>"C:\Program Files\Java\jre1.8.0_111\bin\java.exe" -jar%homepath%/Desktop/Optifine_1.8.9_HD_U_G7.jar
Unrecognized option: -jar\Users\Finn/Desktop/Optifine_1.8.9_HD_U_G7.jar
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

C:\Users\Finn>

 

Bitte Helfen, habe das Problem seid langem. Hinweis: wenn ich Optifine installiere kommt ein Zeichem, was einem weißen Blatt ähnelt und die Dateigröße ist 1.6 Mb

 

LG Gimmigames

Share this post


Link to post
Share on other sites
  • 0

Ich habe mich an die Tipps gehalten, jzt kommt

Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\Finn>"C:\Program Files\Java\jre1.8.0_111\bin\java.exe" -jar %homepath%/Desktop/Optifine_1.8.8_HD_U_H6.jar
Error: Unable to access jarfile \Users\Finn/Desktop/Optifine_1.8.8_HD_U_H6.jar

C:\Users\Finn>"C:\Program Files\Java\jre1.8.0_111\bin\java.exe" -jar E:/Desktop/Optifine_1.8.8_HD_U_H6.jar
Error: Unable to access jarfile E:/Desktop/Optifine_1.8.8_HD_U_H6.jar

C:\Users\Finn>

 

Ich lasse es mal so stehen, wäre nett wenn jmd mir helfen könnte

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×