Jump to content

Hilfe mit PermissionEX "es zickt rum"


FruitieCrab
 Share

Recommended Posts

Hallo Miteinander

Ich habe angefangen mit einem Kollegen einen Server aufzubauen.

Der Server läuft und das Spielen macht enorm Spass darauf. Wir wollten uns den Spassfaktor noch etwas erhöhen und Bukkit Plugins installiern. Dies hat auch geklappt jedoch bekomme ich ein Problem mit dem Plugin PermissionEX. Ich habe es sauber Konfiguriert kann auch Spieler den erstellten Gruppen zuweisen, jedoch bekommt der Spieler diese Meldung, wenn er z. Bsp. den Befehl /sethome, /home, /delhome (vom Homeplugin) eingibt.

"For some reason your name doesnt macht the name in your file, please contact an admin!"

Kann mir jemand helfen? Und mir einen Problemlösungsvorschlag geben? Ich probiere jetzt bereits seit Stunden leider ohne Erfolg.

mfg Fäbe

Link to comment
Share on other sites

Hallo an der Config kann es eigentlich nicht liegen, da ich diese mit einem Tool überprüft habe und im Spiel das Plugin grün angezeigt wird.

Aber die Config gebe ich euch trozdem gerne einmal

Natürlich ohne die "-Zeichen am Ende und Anfang.

Besten Dank für eure Unterstützung.

Permission datei:

"

groups: default: options: default: true prefix: Gast admin: permissions: - '*' options: prefix: '&4[Admin]' member: inheritance: - default permissions: - modifyworld.* - homespawn.player options: prefix: Member v.i.p.: inheritance: - member - default permissions: - modifyworld.* schema-version: 1 users: 0034e827-cafc-46d2-92e9-4f40acb40df7: group: - v.i.p. options: name: Boobsi93 15569b72-b0c2-41e0-b418-b469dfb9257a: group: - admin options: name: FruitieCrab

"

Config Datei:

"

multiserver: use-netevents: true permissions: debug: false allowOps: true user-add-groups-last: false log-players: false createUserRecords: false backend: file informplayers: changes: false basedir: plugins/PermissionsEx backends: file: type: file file: permissions.yml updater: true alwaysUpdate: false

"

Link to comment
Share on other sites

  1. Bei der Gruppe "member" steht der Prefix nicht an Apostrophs.
  2. "v.i.p." könnte eventuell etwas kritisch sein (Punkte in YML-Strukturen stehen AFAIK für einen untergeordneten Ast des "Baums"), das weiß ich aber nicht genau. Versuch einfach mal "vip"

Liebe Grüße,

Baustein

Link to comment
Share on other sites

THeMattaBase a.k.a. René Peter Granat a.k.a. tausende SubAccounts:

Du übertreibst es ernsthaft. Wenn er es nicht weiß ist es eben so. Aber gerade du brauchst dazu nicht deinen Senf abgeben. Normalerweise wären ALLE SubAccounts von dir schon gebannt. Nur dass du es weißt, dieser Account ist nicht gebannt weil du dank der Anderen im Team auf der Beobachtungsliste stehst. Halte dich und deine geistigen Ergüsse in Zukunft zurück.

Amen.

Edited by boomer41
Link to comment
Share on other sites

Frage welche Plugins sind iNtsalliert nicht das irgendein Pluginkonflickt besteht..?

Bis jetzt ist nur das HomePlugin installiert.

  • Bei der Gruppe "member" steht der Prefix nicht an Apostrophs.
  • "v.i.p." könnte eventuell etwas kritisch sein (Punkte in YML-Strukturen stehen AFAIK für einen untergeordneten Ast des "Baums"), das weiß ich aber nicht genau. Versuch einfach mal "vip"

Hej Cool

Danke für den Tipp das werde ich bei gelegenheit gleich ausprobieren und lasse euch wissen wie es aussieht.

Mit freundlichen Grüßen Fäbe

EDIT: Habe es eben probiert es funktioniert leider immer noch nicht. Immer noch der selbe Fehler der mir angezeigt wird.

Edited by FruitieCrab
Link to comment
Share on other sites

Hi,

gibts in der Server-Console (oder im Server.log) eine Ausgabe, wenn der Spieler den Befehl auslöst und dann die Fehlermeldung bekommt?

Ganz doof gefragt, die Groß- / Kleinschreibung des Namen in der Config ist korrekt oder?

Es sollte zwar eigentlich die ID genutzt werden, daher wundert es mich schon, das er den Name anmeckert, der ihm ja eigenltich egal sein kann.

-Yuki

Link to comment
Share on other sites

Hi,

gibts in der Server-Console (oder im Server.log) eine Ausgabe, wenn der Spieler den Befehl auslöst und dann die Fehlermeldung bekommt?

Ganz doof gefragt, die Groß- / Kleinschreibung des Namen in der Config ist korrekt oder?

Es sollte zwar eigentlich die ID genutzt werden, daher wundert es mich schon, das er den Name anmeckert, der ihm ja eigenltich egal sein kann.

-Yuki

Hallo

Der Name stimmt, ich habe auch übers Spiel die User der Gruppe hinzugefügt nicht über die Permission-Datei.

Also mit dem Befehl: "/pex user Boobsi93 group set vip".

Und die Gross-/kleinschreibung habe ich dabei natürlich beachtet.

Und die Ausgabe im Serverlog existiert auch: "Boobsi93 issued server command: /sethome".

Langsam verzweifel ich komplett an dem Mist. Ich hatte auch schon eine andere Version des Permission Plugin installiert und bekomme die gleiche Fehlermeldung.

Link to comment
Share on other sites

Hi,

ansonsten, wenn das auch nichts bringt, kannst du mal bitte die originale Permission *.yml hier an deinen Beitrag anhängen?

Ich mag die .yml nicht so richtig, weil hier jeder kleine "Fehler" extreme Auswirkungen haben kann.

Hier mal ein Punkt zu viel, da mal ein Strich, anstatt einem Tab ein Leerzeichen usw.

Nur um da nochmal sicher zu gehen.

-Yuki

Link to comment
Share on other sites

Banaler Versuch:

Mach den Server aus, lösch betreffenden User aus der permissions.yml raus. Server starten und Beten.

War das erste was ich überhaupt versucht hatte. Hat leider nicht genützt ich habe sogar bereits mehrfach das gesammte Plugin neu installiert.

Sogar verschiedene Versionen die mit meiner Server Version kompatibel sind probiert, leider ohne Erfolg

@Yuki:

Werde ich machen sobald ich zuhause bin

mfg Fäbe

Link to comment
Share on other sites

Hi,

ansonsten, wenn das auch nichts bringt, kannst du mal bitte die originale Permission *.yml hier an deinen Beitrag anhängen?

Ich mag die .yml nicht so richtig, weil hier jeder kleine "Fehler" extreme Auswirkungen haben kann.

Hier mal ein Punkt zu viel, da mal ein Strich, anstatt einem Tab ein Leerzeichen usw.

Nur um da nochmal sicher zu gehen.

So hier habe ich die Permission-Datei für euch.

Ich hoffe es kann mir jemand helfen ich verliere langsam wirklich die nerven daran.

mfg Fäbe

EDIT: Es steht ich hätte keine berechtigung diese Art von Dateil hochzuladen :-(

Link to comment
Share on other sites

Hi,

ich kann erst einmal keinen Fehler sehen. (Falls ich etwas übersehen haben sollte, gern berichtigen).

Du könntest aber mal einen Test machen.

Ersetzte mal beim User die UUID durch den Name und entferne die Options. Es sollte also einfach mal nur so ausseh:

users: Boobsi93: group: - vip

Normalerweise sollte PEX diesen Eintrag selbst wieder ändern, sobald der User den Server betritt, da PEX mit glaub 1.7.irgendwas vom Name auf UUID gewechselt ist.

Hier kommt natürlich auch gleich die Frage auf welche Minecraft Version du für deinen Server verwendest.

-Yuki

Link to comment
Share on other sites

Hi,

ich kann erst einmal keinen Fehler sehen. (Falls ich etwas übersehen haben sollte, gern berichtigen).

Du könntest aber mal einen Test machen.

Ersetzte mal beim User die UUID durch den Name und entferne die Options. Es sollte also einfach mal nur so ausseh:

users:

Boobsi93:

group:

- vip

Normalerweise sollte PEX diesen Eintrag selbst wieder ändern, sobald der User den Server betritt, da PEX mit glaub 1.7.irgendwas vom Name auf UUID gewechselt ist.

Hier kommt natürlich auch gleich die Frage auf welche Minecraft Version du für deinen Server verwendest.

-Yuki

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

ich kann erst einmal keinen Fehler sehen. (Falls ich etwas übersehen haben sollte, gern berichtigen).

Du könntest aber mal einen Test machen.

Ersetzte mal beim User die UUID durch den Name und entferne die Options. Es sollte also einfach mal nur so ausseh:

users:

Boobsi93:

group:

- vip

Normalerweise sollte PEX diesen Eintrag selbst wieder ändern, sobald der User den Server betritt, da PEX mit glaub 1.7.irgendwas vom Name auf UUID gewechselt ist.

Hier kommt natürlich auch gleich die Frage auf welche Minecraft Version du für deinen Server verwendest.

-Yuki

hatte ich bereits probiert

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...
B
B