Jump to content

WorldGuard Spieler Teleport Region fehlende Rechte


Dschingis Khan
 Share

Recommended Posts

Einfach in die permissions.yml gehen - dort ist aktuell der part

groups:
  Spieler:
    default: true
    prefix: '&2[&aSpieler&2]&7 '
    build: true
    permissions:
    - worldguard.region.teleport.zuhause.*

Da die Perms einfach hinzufügen - das sieht dann so aus:

 

groups:
  Spieler:
    default: true
    prefix: '&2[&aSpieler&2]&7 '
    build: true
    permissions:
    - worldguard.region.teleport.zuhause.*
    - essentials.home.bed
    - essentials.sethome.bed
    - essentials.home
    - essentials.sethome
    - essentials.delhome
  • Like 1
Link to comment
Share on other sites

Und ich hab das mal auf einem Server mit den /region teleport getestet:

Wenn du die Region "zuhause" erstellst hast, stell dich in dieser Region an die Position, an der man landen soll

Dann

/rg flag teleport here

eingeben. (Als Admin)

Beim Spieler die Perm

- worldguard.region.teleport.zuhause.*

drin lassen - in den Spieler Rang gehen und nochmal

/rg teleport zuhause

testen

Link to comment
Share on other sites

Ich sag ja LuckPerms bietet Vorteile durch seinen Webeditor etc. Dort siehst du nähmlich sobald du eine Permissionsnode eingibst. Welche Variationen davorn ingame existieren LuckPerms ist meinermeinung nach vielseitiger und Komfortabler...
Als Selbst in den yml dateien Rumzuhantieren.. Einmal in einer Yml eine einrückung vergessen und das Plugin bzw Server startet nicht mehr..

Ich würde den @Dschingis Khan empfehlen auf LuckPerms umzusteigen.
Ich verwende es selbst und es ist für mich auch einfacher als wie Pex... Zumal es auch eine Deutsche Sprachdatei besitzt etc...

Aber das musst du selbst wissen.

Link to comment
Share on other sites

vor 21 Minuten schrieb Bedrock:

/rg flag teleport here

No region could be found with the name of "teleport"

vor 20 Minuten schrieb Bedrock:

in den Spieler Rang gehen und nochmal

Öm. Ich hab mich immer mit OP-Spieler ausgeloggt und mit Nicht-OP-Spieler eingeloggt. Das geht wohl einfacher?

vor 11 Minuten schrieb Squall:

Ich sag ja LuckPerms bietet Vorteile durch seinen Webeditor

Ja bei Pex ist gerade echt der Wurm drin. Aber auch nur in Verbindung mit /rg teleport. Um so mehr möchte ich wissen warum es nicht geht :D Aber ein Wechsel wäre ja schnell gemacht.

Edited by Dschingis Khan
Link to comment
Share on other sites

"/rg flag zuhause teleport here"

Aber der war ja schon gesetzt sonst hätte sich der OP-Spieler doch auch nicht porten können.

Die Berechtigung bei "Spieler" ist hinterlegt. Umgeloggt auf normalen "Spieler". /rg teleport zuhause

Nachricht: You don`t have permission. 😒

Vielleicht müsste ich alle plugins nochmal neu installieren.

Edited by Dschingis Khan
Link to comment
Share on other sites

Nicht

/rg flag zuhause teleport here

Es müsste

/rg flag teleport zuhause here

sein. Ingame kommt dann eine Meldung, dass der Teleport an Kordinate XYZ gesetzt wurde

Die Perm ist

- worldguard.region.teleport.zuhause.*
Link to comment
Share on other sites

vor 6 Minuten schrieb Bedrock:

/rg flag teleport zuhause here

No region could be found with the name of "teleport"

vor 8 Minuten schrieb Bedrock:

/rg flag zuhause teleport here

Ingame kommt dann eine Meldung, dass der Teleport an Kordinate XYZ gesetzt wurde.

vor 10 Minuten schrieb Bedrock:
- worldguard.region.teleport.zuhause.*

Genau so gesetzt. Immer noch: You don`t have permission.

Link to comment
Share on other sites

vor 14 Minuten schrieb Bedrock:

Nicht

/rg flag zuhause teleport here

Es müsste

/rg flag teleport zuhause here

sein. Ingame kommt dann eine Meldung, dass der Teleport an Kordinate XYZ gesetzt wurde

Die Perm ist

- worldguard.region.teleport.zuhause.*

 

Ist nicht ganz richtig ich hab es eben mal bei mir getestet der command lautet richtig

/rg id flag value ... Siehe bild bei mir..

also wäre /rg zuhause teleport here correct

2023-08-17_21_19_07.png.1a384c7fd882b6eab493b9a79c62937d.png

und die permission wäre bei mir : worldguard.region.teleport.testregion ohne dem * am ende

Füge ich da ein Stern rein kommt ebenfalls bei mir No Permission.

bei dir wäre es dann die permission worldguard.region.teleport.zuhause

 

Edited by Squall
Permission geändert.
Link to comment
Share on other sites

Ist der Server öffentlich erreichbar - evtl. könnte ich direkt einen Blick draufwerfen 🤔

 

Gib mal /rg i zuhause ein und hänge ein Screenshot von der Ausgabe mit an

/rg flag zuhause teleport here

ist tatsächlich richtig - komm schon selbst durcheinander^^

Und ja, teste es nochmal mit

- worldguard.region.teleport.zuhause

Und schau, dass es da keine anderen davon gibt

 

Edited by Bedrock
Link to comment
Share on other sites

vor 1 Minute schrieb Bedrock:

Ist der Server öffentlich erreichbar - evtl. könnte ich direkt einen Blick draufwerfen 🤔

 

Gib mal /rg i zuhause ein und hänge ein Screenshot von der Ausgabe mit an

/rg flag zuhause teleport here

ist tatsächlich richtig - komm schon selbst durcheinander^^

 

Ja server ist online aber im Rohbau etc ich müsste dir per webeditor die permissionen geben bzw einige :D wenn du raufkommst kannst du fast gar nix :D

Link to comment
Share on other sites

Nein, der Server ist zur Zeit leider nur im LAN zu erreichen.

Ich versuche jetzt nochmal worldguard.region.teleport.zuhause (ohne* und ohne. am Ende. Bisher nur ohne *)

Ach war ja schon so drin: worldguard.region.teleport.zuhause ohne . am Schluss

Edited by Dschingis Khan
Link to comment
Share on other sites

Das ist echt verwirrend ich selber bin in der gruppe default hab keine owner rechte etc die selbe permission. etc
Und ich kann mich als Spieler zur region via command teleportieren...

Hier scheint irgendwo ein fehler zu sein nur wo... Bis Morgen und Wir helfen wo wir können.

  • Like 1
Link to comment
Share on other sites

Hallo zusammen, es hat mir gestern leider nicht mehr gereicht. Hier noch ein paar Angaben zu den Einstellungen usw.

Ich habe die Region "zuhause" jetzt mal gelöscht, neu erstellt und nur den Teleportpunkt vergeben. Sonst kein Besitzer und nichts.

  1. Die permissions.yml vom Server (Hauptordner) ist leer.
  2. Die permissions.yml vom PermissionsEx:
    groups:
      Spieler:
        default: true
        prefix: '&2[&aSpieler&2]&7 '
        build: true
        permissions:
        - worldguard.region.teleport.zuhause
        - essentials.home.bed
        - essentials.sethome.bed
        - essentials.home
        - essentials.sethome
        - essentials.delhome
        options:
          prefix: '&2[&aSpieler&2]&7 '
          default: true
      Admin:
        build: true
        permissions:
        - '*'
        options:
          prefix: '&9[&bAdmin&9]&f '
          default: false
    users:
      Hier stand die uuid:
        group:
        - Admin
        options:
          name: Chefkoch
      Hier stand die uuid:
        group:
        - Spieler
        options:
          name: Sandra
      Hier stand die uuid:
        group:
        - Spieler
        options:
          name: Luis
      Hier stand die uuid:
        group:
        - Spieler
        options:
          name: Nati
    schema-version: 1
    
  3. Screenshot von der Region. 1934421263_RegionInfozuhause.thumb.png.f50eec6907ca27aec3067af09b73726e.png
  4. Scrennshot vom kein OP-User. (entfällt da gelöst)

OMG! Jetzt wo ich den screenshot von "You don`t have permission." machen will teleportiert sich der "spieler" zum ersten Mal nach hause! :)

Da war wohl irgendwas in den Region-Optionen verstellt. Sonst habe ich seit vorgestern nichts mehr verändert.

Nur den Teleport-Punkt neu zu setzen hatte nicht gereicht. Aber jetzt nach Region löschen und neu erstellen geht es.

Da bleibt nur noch ein grosses DANKE an @Bedrock und @Squall für Eure Hilfe und die Bemühungen!!! 🙏 Ihr habt echt Ausdauer bewiesen.

Es wird bestimmt nicht meine letzte Frage bzw. mein letztes Problem gewesen sein 😆 Aber jetzt muss ich erstmal Ingame aufholen. Meine Freunde ziehen davon und sind schon im End.

Ich wünsche Euch noch ein schönes Wochenende.

Link to comment
Share on other sites

Doch ertmal nichts mit zocken :( Sobald ich den "Spielername" als Owner von "zuhause" setzte kommt beim Teleportationsversuch wieder: You don`t have permission.

Die Spieler sollten aber Türen öffnen, Blöcke abbauen usw. dürfen. Kann ich wohl vermutlich irgendwo in den WG Optionen einstellen aber ist trotzdem ärgerlich irgendwie.

Wenigstens war es jetzt reproduzierbar warum es nicht geht.

Edited by Dschingis Khan
Link to comment
Share on other sites

Nutze auf der Region

/rg flag zuhause use allow

/rg flag zuhause interact allow

/rg flag zuhause build allow

 

build allow reicht wahrscheinlich alleine schon

Edited by Bedrock
Link to comment
Share on other sites

vor 2 Stunden schrieb Bedrock:

Nutze auf der Region

/rg flag zuhause use allow

/rg flag zuhause interact allow

/rg flag zuhause build allow

 

build allow reicht wahrscheinlich alleine schon

Das ist zwar richtig aber Build allow erlaubt auch noch andere dinge...

Wenn er die anderen dinge nicht benötigt sollte auch folgendes gehen:

/rg flag zuhause use allow
/rg flag zuhause block-place allow
/rg flag zuhause block-break allow

vor 1 Stunde schrieb Bedrock:

Und geht es eigentlich mit

worldguard.region.teleport.*

bzw. wenn du als Onwer eingetragen bist

worldguard.region.teleport.own.*

 

Ich hab das mal fix reprozediert , Trage ich mich ih meine Region als Owner ein deop mich selbst und gebe mir zuvor die Permission worldguard.region.teleport.* - So konnte ich mich danach teleportieren..
Nehm ich mich aus der region wieder raus.... funktioniert diese permission nicht..

//Edit es funktionier aber ebenfalls mit der permission: worldguard.region.teleport.own.*

 

Edited by Squall
Was angehängt. da eben reproced.
Link to comment
Share on other sites

vor 12 Stunden schrieb Dschingis Khan:

Die Spieler sollten aber Türen öffnen, Blöcke abbauen usw. dürfen. Kann ich wohl vermutlich irgendwo in den WG Optionen einstellen

Vergesst das wieder. War irgendwie im falschen /gamemode mit dem OP. Sry mein Fehler.

vor 11 Stunden schrieb Bedrock:

worldguard.region.teleport.*

bzw. wenn du als Onwer eingetragen bist

worldguard.region.teleport.own.*

Juhu so geht es jetzt tatsächlich! :D

vor 9 Stunden schrieb Squall:

worldguard.region.teleport.own.*

Ja das funzt! :D

Problem gelöst 👍 Danke, Danke, Danke!

 

Edit: Durch Essentials ist ein neues Problem entstanden. Wenn ich sterbe verliere ich meine Items nicht mehr. Beim /back befehl der einem zum Ort wo mann gestorben ist zurück portet bin ich noch nicht ganz schlüssig. Aber ich möchte es schon realtiv knackig lassen in der Schwierigkeit. Daher auch eher auf false.

/ gamerule keepInventory false bringt nichts. Ausser ich muss den Server noch neustarten.

Edited by Dschingis Khan
Link to comment
Share on other sites

Ich besitze ebenfalls essentials ich schau mal fix ....
Du möchtest das die Spieler die Items verlieren beim Spielen oder behalten?

  1. Ich habe das eben bei mir mal getestet als OP habe ich zuvor gamerule keepinventory auf true gesetzt.. Server nicht neugestartet. Mich danach deops so das ich als normaler spieler war und ich behilt meine items nachdem mich die spinne tötete...
  2. Wieder OP Rechte vergeben. /gamerule Keepinventory false gestellt. Mich selbst deoppt wieder den server nicht neugestartet... und ich verlor meine items

Zudem habe ich folgende Permissionen:

Unbenannt.thumb.PNG.bbba1d56ad8080a68b30e43c0ac2d75f.PNG

Es kann aber auch bei mir so sein das Noch andere Plugins das Inventar verwalten wie zb Multivers-Core glaub ich zumindest. Ich habe ja keinen Blanko server mit nur 1-4 Plugins :)

Edited by Squall
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...
B
B