Jump to content
PyroXs

Minecraft Server laggt bei Aktivierung von Kolben

Recommended Posts

Hallo zusammen!

Ich habe seit ich den Server habe ein Problem und zwar habe ich jetzt schon ein paar Farmen gebaut, die mit Kolben arbeiten bei einigen werden die Kolben sehr oft aktiviert, dadurch sinken dann meine fps auf ca. 20-30, mit weiteren Frame einbrüchen. Das Speil wird dadurch fast unspielbar, komischerweise laggt es aber nicht wenn ich von der Maschine wegschaue 

Server Stats (Nitrado):

2GB RAM

Max. 4 Spieler

Ich habe diese Farmen auch schon im Singleplayer ausprobiert und da laggt nichts rum läuft alles flüssig

Habt ihr vielleicht eine Idee woran das liegen könnte, habe auch schon lange im Internet gesucht, aber kaum was gefunden, bei manchen hängen die laggs mit plugins wie worldguard oder lwc zusammen, aber ich habe kein solches plugin installiert. Wisst ihr vielleicht ob bei Nitrado dafür eine Standardeinstellung gibt, also ohne Plugin?

Share this post


Link to post
Share on other sites

Müssen diese Kolben dauerhaft laufen? es währe ein großer Vorteil wenn sie mit einer Clock von 1 Minute oder mit observern laufen 

Share this post


Link to post
Share on other sites

Bei 2 meiner Maschinen ja, sind 0 Tick Bambus- und Zuckerrohrfarmen

außerdem habe ich noch eine Wollefarm wo man den Lag auch spürt/sieht wenn sich ein Kolben sich aktiviert

Share this post


Link to post
Share on other sites

Hi,

willkommen in der Welt von Minecraft und Mojang.

Es gibt einen sehr interessanten "Bug", oder sollte ich besser sagen eine bescheidene Designentscheidung von Mojang, welche bewirkt, dass ein Server beim aktivieren eines Pistons ein Datenpaket zum Client sendet, dass dieser den Piston-Sound abspielen soll. Normalerweise sollte ein Server sowas garnicht machen, dass kann der Client selbst entscheiden, wenn er vom Server die Aktivierung des Pistons übermittelt bekommt.

Das Problem hierbei ist nämlich, dass der Server nun deinen Client - gerade bei 0-Tick-Farmen - mit diesen Sound-Paketen zuspammt und dieser daraufhin natürlich "laggt" solange du halt in der Nähe bist.

Es gibt aber auch noch andere mögliche Ursachen welche je nach MC Version mehr oder weniger zu extremen Laggs führen. Dies können Lichtupdates sein, welche durch die Pistons ausgelöst werden oder einfach der tolle (1.14 - pre 1.14.3) Bug mit Pistons an Chunkgrenzen, welche extreme Clientlaggs verursachen.

Normale Piston-Laggs kann man teilweise ein bisschen durch die Verwendung von Optifine in den Griff bekommen, bei anderen dagegen hilft nur diese zu verwenden, wenn es wirklich nötig ist.

 

-Yuki

  • Like 1

Share this post


Link to post
Share on other sites

Von dem Chunkgrenzen Bug habe ich auch schon gelesen unglücklicherweise sind beide Maschinen genau an Chunkgrenzen

Ich probiers dann nochmal mit einem Piston in der Mitte von einem Chunk, da es selbst bei der Aktivierung von 1 Kolben auch kurzzeitig laggt

Optifine probier ich dann auch nochmal, aber gibt es wirklich keine Lösung dafür???

 

Share this post


Link to post
Share on other sites

Also das Problem ist jetzt gelöst hatte auch nochmal den nitrado support angeschrieben, die haben die server hardware getauscht und dann lief es besser, dann hab ich mir nochmal Optifine installiert und jetzt läuft alles wieder super flüssig.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×