Jump to content

Hast du schon das Minecraftforum.de-Gütesiegel gesehen? Hier kommst du dorthin!

  • 0
Sign in to follow this  
chaolo2

Error bei codechicken lib

Question

Hallo zusammen

 

ich möchte ein Signalsystem bauen und benötige dafür Redproject und code chicken usw. Alles was man braucht eingefügt nur stürzt das Spiel nun immer ab. Leider bin ich kein PC Profi und kenne mich damit nicht sehr gut aus.

---- Minecraft Crash Report ----
// Oops.

Time: 18.04.19 10:01
Description: There was a severe problem during mod loading that has caused the game to fail

cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: codechicken/lib/packet/PacketCustom$ICustomPacketHandler
    at cpw.mods.fml.common.LoadController.transition(LoadController.java:163)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:544)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:208)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:480)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
    at net.minecraft.client.main.Main.main(SourceFile:148)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
Caused by: java.lang.NoClassDefFoundError: codechicken/lib/packet/PacketCustom$ICustomPacketHandler
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:348)
    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:440)
    at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
    at com.google.common.eventbus.EventBus.post(EventBus.java:275)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:212)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:190)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
    at com.google.common.eventbus.EventBus.post(EventBus.java:275)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:119)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:513)
    ... 10 more
Caused by: java.lang.ClassNotFoundException: codechicken.lib.packet.PacketCustom$ICustomPacketHandler
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:101)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 34 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
    Minecraft Version: 1.7.10
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_51, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 105802584 bytes (100 MB) / 301989888 bytes (288 MB) up to 2147483648 bytes (2048 MB)
    JVM Flags: 8 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx2G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1558 54 mods loaded, 54 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UC    mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
    UC    FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
    UC    Forge{10.13.4.1558} [Minecraft Forge] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
    UC    AppleMilkCore{1.1.0} [AppleMilkCore] (minecraft.jar)
    UC    PotionExtensionCore{1.7.10-1.1.0} [PotionExtensionCore] (minecraft.jar)
    UC    DCsAppleMilk{1.7.10_2.9n} [Apple&Milk&Tea!] (Apple&Milk&Tea!.jar)
    UC    DCsNEIPluginAMT{1.7.10_1.0a} [NEIPluginForAMT] (Apple&Milk&Tea!.jar)
    UC    ArchitectureCraft{1.7.2} [ArchitectureCraft] (ArchitectureCraft.jar)
    UC    speedytoolsmod{2.0.0} [Build Faster Mod] (Build-Faster-Mod-1.7.10.zip)
    UC    BuildCraft|Core{7.1.23} [BuildCraft] (buildcraft-7.1.23.jar)
    UC    BuildCraft|Transport{7.1.23} [BC Transport] (buildcraft-7.1.23.jar)
    UC    BuildCraft|Factory{7.1.23} [BC Factory] (buildcraft-7.1.23.jar)
    UC    BuildCraft|Silicon{7.1.23} [BC Silicon] (buildcraft-7.1.23.jar)
    UC    BuildCraft|Robotics{7.1.23} [BC Robotics] (buildcraft-7.1.23.jar)
    UC    BuildCraft|Energy{7.1.23} [BC Energy] (buildcraft-7.1.23.jar)
    UC    BuildCraft|Builders{7.1.23} [BC Builders] (buildcraft-7.1.23.jar)
    UC    ComputerCraft{1.75} [ComputerCraft] (ComputerCraft1.75.jar)
    UC    creativecore{1.3.14} [CreativeCore] (CreativeCore+v1.3.24+mc1.7.10.jar)
    UC    PTRModelLib{1.0.0} [PTRModelLib] (Decocraft-2.4.2_1.7.10.jar)
    UC    props{2.4.2} [Decocraft] (Decocraft-2.4.2_1.7.10.jar)
    UC    Eln{@[email protected]} [Electrical Age] (ElectricalAge-1.14.2.jar)
    UC    excore{1.5.3} [EXCore] (EXCore.jar)
    UC    fairylights{1.4.0} [Fairy Lights] (Fairy Lights.jar)
    UC    flenixcities{0.16.1} [FlenixCities] (FlenixCitiesCore.jar)
    UC    fc_food{0.7.0} [FlenixCities Food] (FlenixCitiesFood.jar)
    UE    ForgeMultipart{1.2.0.345} [Forge Multipart] (ForgeMultipart-1.7.10-1.2.0.345-universal.jar)
    UE    McMultipart{1.2.0.345} [Minecraft Multipart Plugin] (ForgeMultipart-1.7.10-1.2.0.345-universal.jar)
    UC    germansignsatrails{1.7.10-1.0.0} [Germans Signals at Rails] (germanssignalsatrails-1.7.10-1.0.5.jar)
    UC    KerberosCore{1.0.10} [Kerberos's MOD Core] (Kerberos's MOD Core.jar)
    UC    HalogenLight{1.0.5} [Halogen Light] (Halogen Light.jar)
    UC    IC2{2.2.822-experimental} [IndustrialCraft 2] (industrialcraft-2-2.2.822-experimental.jar)
    UC    SlimevoidLib{2.0.4.7} [Slimevoid Library] (SlimevoidLibrary-2.0.4.7.jar)
    UC    LittleBlocks{2.2.4.4} [Little Blocks] (Little Blocks.jar)
    UC    malisiscore{1.7.10-0.14.3} [MalisisCore] (malisiscore-1.7.10-0.14.3.jar)
    UC    malisisdoors{1.7.10-1.13.2} [Malisis' Doors] (malisisdoors-1.7.10-1.13.2.jar)
    UC    MrTJPCoreMod{1.1.0.33} [MrTJPCore] (MrTJPCore-1.1.0.33-universal.jar)
    UC    nifty{1.11} [NiftyBlocks] (NiftyBlocks-1.11.jar)
    UC    NiftyBlocksMultipart{1.4} [NiftyBlocksMultipart] (NiftyBlocks-1.11.jar)
    UC    placeableitems{2.0.1} [Placeable Items Mod] (placeableitems-2.0.1.jar)
    UE    ProjRed|Core{4.7.0pre12.95} [ProjectRed Core] (ProjectRed-1.7.10-4.7.0pre12.95-Base.jar)
    UE    ProjRed|Integration{4.7.0pre12.95} [ProjectRed Integration] (ProjectRed-1.7.10-4.7.0pre12.95-Integration.jar)
    UE    ProjRed|Transmission{4.7.0pre12.95} [ProjectRed Transmission] (ProjectRed-1.7.10-4.7.0pre12.95-Integration.jar)
    UC    Railcraft{9.12.2.1} [Railcraft] (Railcraft_1.7.10-9.12.2.1.jar)
    UC    row{1.7.10-5.8-RC7} [Rails of War] (Rails-of-War-Mod-1.7.10.jar)
    UC    RandomThings{2.2.4} [Random Things] (Random Things.jar)
    UC    RedstonePasteMod{1.6.2} [Redstone Paste] (RedstonePasteMod-1.7.10-1.6.2.jar)
    UC    RentServer{1.0} [§l§2Rent Server Mod] (RentServerMod.jar)
    UC    roadstuff{1.0.3-final} [Road Stuff] (RoadStuff-mc1.7.10-1.0.2-final.jar)
    UC    srsm{1.7.10-1.0.4} [Saracalia's Random Stuff Mod] (SRSM-1.7.10-1.0.4.jar)
    UC    tc{4.4.1_019} [Traincraft] (Traincraft-4.4.1_019.jar)
    UC    cfm{3.4.7} [§9MrCrayfish's Furniture Mod] (§9MrCrayfish's Furniture Mod.jar)
    UC    Monoblocks{11.6} [§cMonoblocks] (§cMonoblocks.jar)
    UC    MonoblocksMultipart{11.6} [MonoblocksMultipart] (§cMonoblocks.jar)
    UE    ForgeMicroblock{1.2.0.345} [Forge Microblocks] (ForgeMultipart-1.7.10-1.2.0.345-universal.jar)
    GL info: ' Vendor: 'Intel' Version: '4.4.0 - Build 20.19.15.4624' Renderer: 'Intel(R) HD Graphics 5500'

 

Viele Grüße

chaolo2

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Habe es eingefügt nun wird mir angezeigt:

 

Forge Mod Loader has found a problem with your minecraft installation

The mods and versions listed below could not be found

CodeChickenCore : minimum version required is 1.0.3

The file 'logs/fml-client-latest.log' contains more information

 

Habe die Version geändert aber nichts hilft :(

Share this post


Link to post
Share on other sites
  • 0

Hi,

du hast von meinem Link oben die aktuelle Version 1.0.7.47 geladen und in den "mods"-Ordner?

Kannst du mal bitte wie angegeben die "fml-client-latest.log" an deinen Beitrag anhängen? Also bitte die komplette Datei anhängen nicht Teile oder so als Text posten.

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

Habe nun die Mods nacheinander eingefügt und habe nun herausgefunden das es am Mod chickenchunks liegen muss. Ohne diesen läuft Minecraft und bekommt nicht die Meldung der falschen Version. Habe dir mal die gewünschte Datei angehangen.

 

 

fml-client-latest.log

Edited by chaolo2

Share this post


Link to post
Share on other sites
  • 0

Hi,

du verwendest im Moment

Zitat

MinecraftForge v14.23.1.2555 Initialized

und dein Problem ist

Zitat

The mod railcraft (Railcraft) requires mod versions [[email protected][14.23.5.2779,)] to be available

Die Version von RailCraft, die du verwenden willst, will eine neuere Version von Forge.

Die Version von Forge ist aber auch recht alt vom 26.11.2017

Also entweder Forge aktualisieren oder eine ältere Version von RailCraft verwenden, welche mit der alten Forge Version klar kommt.

 

Ganz davon ab, überprüfe mal bitte die 2 Mods:

Zitat

[23:45:21] [main/WARN] [FML/]: Zip file BiblioCraft[v2.4.3][MC1.12.0].jar failed to read properly, it will be ignored

Zitat

[23:45:21] [main/WARN] [FML/]: Zip file furniture-5.2.1-1.12.2.jar failed to read properly, it will be ignored

Anscheinend sind die Mod-Dateien defekt, also vielleicht nochmal neu herunterladen.

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

Danke für deine Hilfe. Wie aktualisiere ich Forge?

Bibliocraft dürfte im Mod Mr.Crayfish Furniture mit drin sein und diesen Mod hat der Mod installer wohl aktualisiert auf die neuste Version. Nur leider scheint in dem Mod irgendwo ein Fehler drin zu sein. Jedesmal wenn ich dort aus der Kategorie Markt etwas bauen möchte stürzt das Spiel sofort ab.

 

 

 

Share this post


Link to post
Share on other sites
  • 0

Hi,

also im Grunde nur Forge herunterladen und Installieren ( http://files.minecraftforge.net/ ). Es legt automatisch ein Profil im StandardLauncher an. Solltest du einen anderen Launcher verwenden, musst du schauen, wie du das dort anpassen kannst.

Kannst du in dem Modinstaller die Forge Version eventuell anpassen?

Aber Vorsicht, bevor du die Forge Version wechselst, erstelle unbedingt ein Backup vom kompletten Modpack und deinen Welten, so dass du im Notfall alles Rückgängig machen kannst.

Wenn du Forge aktualisierst, kann es passieren, dass dann andere Mods Probleme machen, welche eventuell eine ältere Version wollen oder einfach mit der aktuellen nicht klar kommen, daher ist sowas immer mit ausreichend Vorausplanung zu machen. Forge ist halt der Grund und darauf bauen die Mods auf.

Einfacher für dich wäre natürlich eine ältere Version von Railcraft zu verwenden, aber dass musst du am Ende selbst entscheiden, ob du es versuchst und was du dir zutraust.

 

-Yuki

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×