Jump to content

Hast du schon das Minecraftforum.de-Gütesiegel gesehen? Hier kommst du dorthin!

  • 0
ZebulonHH

Performance Problem der Java Engine nach Minecraft Start?

Frage

Hallo, insbesondere Technik-Versierte.

Nach zwei Jahren bin ich wieder aktiv mit Minecraft. Ausstiegs-Gründe waren hauptsächlich MOD-Problematiken, teils auch Performance.

Nun seit einem Jahr neuer Gaming PC mit Win 10, 16 GB, SSD, NVidia 1050 Ti.

Im Oktober war noch alles weitgehend fein und Performance-Einbußen waren eher selten.
Nun habe ich das aber zu oft und verstehe die Welt nicht mehr.

Problematik:
Nachdem das Spiel (und damit Java) geladen sind, wird oftmals schon der Kamera-Schwenk des Hintergrundbilds hinter dem Hauptmenü von MC nicht fließend bewegt, sondern stockt alle wenigen Sekunden für einen Sekundenbruchteil. Das Gleiche oder zumindest in ähnlichen Phasen passiert auch im Spiel auf einer Einzelspieler-Welt.

Extrem zu sehen, wenn es regnet, denn dann bleibt der Regen alle 2-3 Sekunden für einen Bruchteil einer Sekunde stehen.

FPS ist überwiegend gut und fällt aus der Betrachtung raus, zumal überall anders (außer Creativerse) keine Einschränkungen zu bemerken sind. Daher Thema Java und nicht GraKa, Hardware oder GUI.

MC bekommt über Java bis zu 4GB zur Verfügung, wie man an folgendem Profil-Eintrag für die VM sehen kann:
-Xmx4G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M

Und noch vorweg genommen: Das Austauschen der von Mojang "mitgelieferten" JVM 8.51 gegen eine wesentlich Neuere, bringt hier genau gar nichts.

Um den Aufwand nicht gleich im Vorwege auf die Spitze zu treiben, habe ich bisher keine Debugging-Versuche unternommen. Da frage ich lieber erst einmal in die Runde nach guten Ideen, denn augenblicklich stehe ich ein wenig auf dem Schlauch. 😕

Update (+5 Min.): Ich vergaß - ich nutze gerade überwiegend eine Konfiguration für die Snapshots, ergo MC V1.14. Die V.1.13.2 mit Optifine macht augenblicklich mehr Laune. 😉

Gruß vom Zebulon.

bearbeitet von ZebulonHH

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

3 Antworten auf diese Frage

Empfohlene Beiträge

  • 0

Hi,

um ehrlich zu sein nein 😕

Bei dem System solltest du normalerweise absolut keine Probleme haben (mal von größeren Packs mit Shader abgesehen die immer laggen).

Hab deinen Beitrag schon 2-3 mal gelesen, ob mir was brauchbares einfällt, aber was du da beshreibst ist ein echt merkwürdiges Phänomen.

Ich gehe davon aus, dass es ein Desktop PC ist und kein Notebook oder? Falls es doch ein NB sein sollte, prüfe bitte nochmal Ingame ob auch wirklich die 1050 TI verwendet wird (F3-Screen oben rechts).

Ansonsten natürlich die Frage, was hat sich seit Oktober verändert? Hast du das Win10 Oktober Update installiert (<Win-Taste>+R nnd "winver" - 1809)? Sonstige Hintergrund-Software neu? Grafiktreiber / -Einstellungen mal zurückgesetzt (Neuesten Treiber runterladen - Bei Installation "Benutzerdefiniert" und Häkchen setzen bei "Neuinstallation")? Wieviele FPS werden denn Ingame angezeigt (F3-Screen oben links) bei Stillstand und bei Bewegung?

 

-Yuki

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Hallo Yuki,

habe Deine Mitteilung vor einigen Minuten mitbekommen und vielen Dank, dass Du Dir ein wenig Zeit für das Thema genommen hast.

Ich denke PC oder NB wäre erste einmal unerheblich. Dies hier ist ein Gaming Notebook von MSI. Windows hat hier die V. 1803.

Eben habe ich pro Forma nochmal einige Profile aufgerufen.
1) V.1.13.2 ohne Alles - leichte lags.
2) V.1.13.2  mit Optifine - leichte lags.
3) V.1.14, Snapshot 18w46a - flüssig.  (? - oops)
4) nochmals kpl. raus, nochmals die 18w46a, Hauptmenü, Kamerschwenk auch wieder flüssig. Wenn ich bei der Weltauswahl KEINE Welt auswähle und NUR die Maus im Kreis bewege, bleibt der Mauszeiger immer mal kurz hängen.
5) Welt im Snapshot geladen und es geht flüssig und meist FPS Raten zwischen 30 und knapp 60 Frames. Von dem Punkt okay.
Hierbei auch ständig umher gelaufen, Blick auf eigene Hütte im Forest Biom, etliche Tiere in der Umgebung.

Was Treiber angeht: MSI versorgt die Maschine bei Neuerscheinungen halbautomatisch mit neuen Treibern. Die Erfahrung ist aber, dass Treiber-Updates oftmals keine Rolle spielen, auch wenn das oft irgendwo mitgeteilt wird. Wird völlig überschätzt. Insbesondere wenn man Spiele spielt, die älter sind und die Maschinen weit, weit überlegen, weil Jahre neuer sind.

Ich müsste Minecraft auch dann flüssig spielen können, wenn nebenbei einige Youtube Videos laufen würden und das System-eigene Recording läuft. (NVidia) Ich tippe intuitiv immer noch auf den Onkel Java. 🙂
Auch wenn ich noch keinen Lichtblick auf das richtig Detail habe. Zugegeben habe ich immer noch auch wenig Laune, mich um's Java Debugging zu bemühen, wo dann auch noch fraglich ist, ob ich da ohne Erfahrung auf ein vernünftiges Ergebnis komme.

LG, Zebulon.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×