Jump to content

Zeichen werden falsch formattiert? (Console)


phibrosof
 Share

Recommended Posts

Vielen Dank erstmal für deine Hilfe.

Ich muss dir jedoch sagen, dass ich keinen Plan habe, was "escape-escapen" und "alles in einen string setzen" bedeuten soll. Ich habe nur Zugriff auf den Gameserver an sich, weil ich mich mit Linux&Co. nicht auskenne.

Hast du zufällig Skype, dann könnten wir das irgendwie so machen, dass du mit dem Supporter schreibst, dann kannsde dem erklären was er machen muss bzw. Dass du mir sagst was ich dem schreiben soll ^-^

Gesendet von meinem GT-I8190 mit Tapatalk

Edited by phibrosof
Link to comment
Share on other sites

Mit "Escape Escapen" meine ich sowas in der art: <\\Name\\> (oder versuch <\Name\>) das heißt, den Escaper Escapen ^^

Meine Zweite Idee: BlablaCommand "<Name>"

Weiß aber überhaupt nicht, ob das überhaupt geht...

Edited by Corona
Link to comment
Share on other sites

Es kann daran liegen, dass der Hoster Sonderzeichen escaped zum Schutz vor Code-Injection. Aber wie gesagt, ich hab keine Ahnung :3

Hast du es schon mal in Minecraft probiert? also Ingame?

Joa, Ingame funktionierts. Und das Problem tritt nicht nur beim Listener auf, sondern auch bei z.B. /say

Link to comment
Share on other sites

So! Ich hatte heute ein ausführliches Gespräch mit dem Supporter:

Ein Berater wird jetzt kontaktiert, bitte haben Sie einen Augenblick Geduld.


*Zensiert* betritt den Chatraum.	



*Zensiert*	21:00:18		

Guten Tag Paul, mein Name ist *Zensiert*. Wie kann ich Ihnen helfen?	

Paul	21:02:22		

Hallo, ich hatte sie gestern bereits kontaktiert: http://s1.directupload.net/images/140202/7cyzpmqk.jpg Dort haben sie mir gesagt, ich solle mich mal in Foren erkunden, und das habe ich nun gemacht: http://www.minecraftforum.de/topic/3250-zeichen-werden-falsch-formattiert-console/ + http://minecraft-server.eu/board/showthread.php?20863-Zeichen-werden-falsch-formattiert-(Console) In beiden Foren wird eher ihnen, bzw. ihren System der Fehler zugeschrieben, könnten sie sich das bitte mal ansehen und den Fehler ggbf. beheben?

*Zensiert*	21:04:17		

Auf dem Hostsystem ist alles soweit korrekt konfiguriert. Da es ja speziell um unsere Server geht, hatte ich Ihnen eigentlich gesagt, dass Sie sich an UNSER Forum wenden sollen: http://community.zap-hosting.com	

Paul	21:05:19		

Aber daher ja auch /say falsch funktioniert, liegt es ja nicht an dem Plugin. /say ist ja Bestandteil der Bukkit Software.

*Zensiert*	21:05:53		

Ich denke, Sie haben das Problem nicht korrekt verstanden. Ich weiß nicht, wie ich es sonst noch erklären soll.	


Wenden Sie sich bitte an unser Forum, dort kann man Ihnen sicher weiterhelfen. Sorry, mehr kann ich da leider nicht tun.	



Paul	21:08:31		

Sie haben mir doch noch gestern erklärt, das Problem würde an meinem Plugin liegen, weil es ja aber bei anderen Hostern und auch auf privaten Hamachi - Servern keine Fehler versursacht, liegt es ja an ihrem System. In beiden Threads werden ihnen ja Lösungsvorschläge unterbreitet:

*Zensiert*	21:09:17		

Jein. Das Problem ist dass das Plugin die Escape-Sequenzen des Linux Systems bzw. der Console falsch auswertet.	


Durch Anpassen des Plugins kann man das beheben.	



Paul	21:09:29		

"Es kann daran liegen, dass der Hoster Sonderzeichen escaped zum Schutz vor Code-Injection. " und "Kann ebenfalls sein, dass der Hoster die locale (Systemsprache) nicht oder falsche gesetzt hat auf dem Hostsystem." , könnne sie diese Fehler denn schon auschließen.


In einem Thread schrieb übrigens auch einer, dass das auf Linux aber einwandfrei funktionieren würde [...]	



Können sie mir das Plugin denn dann anpassen, wenn es daran liegt?	

*Zensiert*	21:11:11		

Wie bereits mitgeteilt: Es ist die Kombination.	


Nein, dafür geben wir nämlich keinen Support.	



Nochmal: Wenden Sie sich bitte an UNSER Forum: http://community.zap-hosting.com	


Dort sind genug Leute, die mit unseren Systemen vertraut sind und bestimmt eine Lösung haben.	



Paul	21:14:25		

Kann es denn nicht an der Linux Version o.ä. liegen? Ich werde mich an ihr Forum wenden, aber vorher schauen sie sich das Problem bitte genau an, und schließen aus, dass es sicher nicht an ihrem System liegt! Denn wenn /say nicht funktioniert, was ja fest in die Bukkitsoftware integriert ist, dann liegt es doch eher an ihrem System. Bei anderen Hostern und privaten Servern klappts doch auch, wieso also NICHT hier?


Würde vielleicht ein Neuaufsetzen des Servers Abhilfe schaffen?	



*Zensiert*	21:15:18		

Ich hatte mir das Problem bereits gestern angeschaut, ich konnte da nichts unternehmen, Sorry.	


Das können Sie versuchen, jedoch kann ich dafür nicht garantieren.	



Paul	21:16:28		

Haben sie denn vielleicht einen Kollegen, der sich mit Linux und Bukkit Server auskennt?

*Zensiert*	21:16:50		

Ich bin allein hier, daher nein.	


Und das was Sie da vorhaben, liegt nicht in unserem Supportbereich. Daher wird man Ihnen dazu hier generell nicht weiterhelfen können.	



Paul	21:18:02		

Denn sie können ja auch nicht ausschließen, dass es an ihrem System liegt, oder irre mich? Kann ich mich dann vielleicht an einen ihrer Techniker wenden (Email o.ä.) , denn das Problem ist wirklich äußerst verärgerlich.

*Zensiert*	21:18:46		

Ich habe Ihre Fragen nun alle bereits mehrfach beantwortet.	


An einen Techniker verweisen kann ich Sie nicht, ich sagte NICHT, dass es an unserem System liegt.	



Paul	21:19:35		

Sie konnten mir aber auch nicht sagen, dass es sicher nicht an ihrem System liegt.

*Zensiert*	21:19:46		

Und zum letzen Mal: Das ist Angelegenheit des FORUMS.	


Ich werde das Gespräch nun beenden. Was Sie tun können, wissen Sie ja nun.	



Einen schönen Abend wünsche ich noch.	

Paul	21:20:18		

Auf Wiedersehen.

System	21:20:30		

*Zensiert* hat das Gespräch verlassen.


Ihr Berater hat das Gespräch soeben verlassen, sollten Sie weitere Fragen haben können Sie uns eine Nachricht hinterlassen. Vielen Dank!

Und nun?

Edited by Baustein
Link to comment
Share on other sites

Ich hab echt keine Ahnung, aber sowas ist echt kein Support, immerhin zahlst du ja für das Produkt!

Joa eben.

Aber ein Wechsel ist leider nicht möglich, ich habe dort einen Lifetime - MC - Server. (Jaja, wenn man jung ist ist man so naiv, und man glaubt, dass man noch im Altenheim MC spielen wird - Vorrausgesetzt bis dahin sind die nicht pleite:D)

Link to comment
Share on other sites

#Support-Post editiert, hast einmal vergessen, den Namen zu zensieren.

Deswegen mache ich das immer so: post-1745-0-47091200-1391519548_thumb.pn

@phibrosof Gibt es einen guten Grund warum du dich NICHT an das Forum wendest auf das dich der Supporter hinweist? (http://community.zap-hosting.com)

Grundsätzlich wäre ich mir auch nicht sicher, dass der Hoster wirklich schuld ist. Was funktioniert denn genau nicht? Kannst du mit anderen Plugins auf Namen zugreifen oder haben alle Plugins dieses Problem? Kannst du ansonsten an der Konsole solche Befehle benutzen?

mfg kivi

Link to comment
Share on other sites

Soetwas wie wird in der Konsole falsch formattiert, auch mit anderen Plugins, ja.

Ich werde mich ja auch an das Forum des Hosters wenden, aber ich hatte nun mal vorher diesen Post hier erstellt, den wollte ich dann halt auch auf dem aktuellen Stand halten.

Gesendet von meinem GT-I8190 mit Tapatalk

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...
B