Jump to content
  • 0
Djdodotech

Minecraft Server mit mehr Arbeitsspeichern starten auf einem Macbook!!

Question

Hallo liebe Gemeinde! 

Ich habe ein kleines Problem bei dem ich eure Hilfe gebrauchen kann! Es geht um folgendes Problem!

Wir haben uns für unsere Hausgemeinschaft einen Minecraft Sever von Spigot erstellt auf dem wir gemeinsam auf einer Plotworld bauen! Soweit so gut, nun meldet mir der Server immer wieder die Meldung Can't keep Up! Is the Server overloaded? ! 

Ich habe mir darauf hin das Internet durchsucht und nach einer Lösung gesucht, weil der Server bei mehreren Spielern immer wieder einige spieler aus dem Game wirft und wollte dem Spiel mehr Ram zur verfügung stellen auf dem Mackbook! 

Ich habe eine start.command erstellt mit folgendem Inhalt:

#!/bin/bash
cd “$(dirname “$0”)”
exec java -Xms4G -Xmx4G -jar spigot.jar

Nach dem erstellen habe ich der start.command und auch der spigot.jar chmod a+x gegeben damit diese auch die benötigten Rechte hatten, und habe die Start.command ausgeführt! 

Das Ergebnis war leider nicht das erhoffte und ich bekam die Fehlermeldung:

Last login: Thu Jul 23 12:14:03 on ttys000
/Users/djdodotech/Desktop/Spigot/start.command ; exit;                          
[email protected] ~ % /Users/djdodotech/Desktop/Spigot/start.command ; exit;
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

[Prozess beendet]

Eigentlich sollte sich jetzt die Console öffnen und laut Anleitung der Server mit 4 GB Ram starten!! Dies passiert aber nicht! 

Und wenn ich nur per Terminal starten möchte mit dem Befehl:

-Xms4G -Xmx4G -jar minecraft_server.jar

Bekomme ich die Fehlermeldung das meine Java version nicht stimmt, und Java 13 benötigt wird! Obwohl die JDK 14 schon auf meinem Mac installiert ist!Die Fehlermeldung ist wie folgt:

Last login: Thu Jul 23 12:41:38 on ttys000
[email protected] ~ % cd /Users/djdodotech/Desktop/Spigot 
[email protected] Spigot % java -Xms4G -Xmx4G -jar minecraft_server.jar
Unsupported Java detected (58.0). Only up to Java 13 is supported.
[email protected] Spigot % 

Wie man sehen kann habe ich die AKtuelle Java bereits installiert:

Last login: Thu Jul 23 12:46:46 on ttys001
[email protected] ~ % export JAVA_HOME='/Library/Java/JavaVirtualMachines/jdk-13.0.2.jdk/Contents/Home'
[email protected] ~ % 

Kann mir hier jemand helfen? würde gern dem Server mehr Arbeitsspeicher zuweisen aber irgend wie führen alle Bemühungen ins Leere und ich weis gerade leider nicht weiter! Vielen Dank schon mal im voraus und ich hoffe jemand kennt sich mit der Materie aus!

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Unsupported Java detected (58.0). Only up to Java 13 is supported.

Da steht nicht, dass er _keine_ Version findet, sondern dass die Version *zu neu* ist.

Du musst hier Java bis zur Version 13 verwenden.

Link to post
Share on other sites
  • 0
Gerade eben schrieb boomer41:
Unsupported Java detected (58.0). Only up to Java 13 is supported.

Da steht nicht, dass er _keine_ Version findet, sondern dass die Version *zu neu* ist.

Du musst hier Java bis zur Version 13 verwenden.

Die habe ich ja verwendet! dann sagt er mir aber Cant acess Jar file 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...
B