Jump to content
  • 0
Steppenfire

Mod ExtraBees: "Mysticale Königin" erkennt keine Blumen [1.7.10]

Question

Posted (edited)

Hallo zusammen,

ich habe mir über 'Extra Bees' aus der Binnie-Mod (v. 1.7.10-2.0.20) eine Mysticale Königin gezüchtet (Noble Prinzessin + Klösterliche Drone).

Lt. Bienalyzer benötigt die Mysticale Königin "Mystical" Flower aus der ebenfalls installierten Mod Botania (v. r1.8-249) um Dronen und Items zu produzieren.

Allerdings erhalte ich im Industriellen Bienenstock permanent nur die Meldung, dass keine Blumen gefunden werden können, obwohl ich neben den Standard-Mystical-Flower, welche man überall in der Welt findet, auch schon alle weiteren Botania-Blumen-Typen neben dem Bienenstock platziert habe.

 

Meine bisherigen Recherchen brachten mich nur auf das GitHub-Issue-Page Forum, wo der Bug wohl schon unter einer 1.11-Version gemeldet wurde.

Wie dort vermerkt gibt es zwei 'Mystical Bees': 1x aus der Mod 'Mystical Bee', welche ich ebenfalls in Version 1.7.10-2.4.4 installiert habe (diese benötigt 'normale' Blumen)

Und 1x aus der Mod 'Extra Bees' (diese sollte mit den Botania-Mystical Flowers zu produzieren beginnen.

 

Leider bin ich jedoch technisch nicht weit genug versiert um sagen zu können, ob dort jemand eine Lösung gefunden hat und falls ja, ob die im selben Thread hier aufgeführten Änderungen sich diese durch eine manuelle Modifikation der Binnie-Mod-JAR-File ebenfalls unter 1.7.10 lösen ließe, bzw. wie ich hier vorgehen müsste.

Ich habe mir zwar mal JD-GUI heruntergeladen und die File geöffnet um mir zumindest bestätigen zu lassen, dass in meiner Version ebenfalls unter "Mystical"-Flower-Type auf die Botania-Mod verwiesen wird - doch zu viel mehr reicht leider mein Code-Verständnis nicht aus :(

Vielen Dank und beste Grüße,

Steppenfire

 

Bienalyzer.PNG

Binnie-Mod.PNG

Edited by Steppenfire

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Hi,

die von dir verlinkte Änderung ist im "master-MC1.12", also für die 1.12er Version.

Soweit ich weiß gibt es seit 2017 keine neuen Versionen mehr für 1.7 also wird diese Anpassung dort auch nicht mehr landen. Du selbst kannst diese Änderung nur bedingt vornehmen. Du müsstest halt den Quellcode für den 1.7 Mod laden und dort selbst die Änderung suchen, anwenden und dann den Mod neu kompilieren (da brauchst du dann schon ein bisschen wissen in Java und Entwicklung). Meist ist es aber nicht ganz so einfach, da sich ein Mod oft zwischen 1.7 und 1.12 massiv verändert hat und da eine Anpassung vornehmen ist oft recht aufwendig, vorallem wenn man sich erst in den Mod einarbeiten muss.

tldr; Wenn es mit den letzten Updates der Mods nicht geht, wirst du warscheinlich nicht viel Glück haben.

 

-Yuki

Share this post


Link to post
Share on other sites
  • 0

Hi,

das ist schade, aber hatte mir schon fast gedacht, dass es nicht ganz trivial ist so eine Mod dann zu korrigieren.

Dann wird es ohne die Mysticale Biene gehen müssen :) Vielen Dank auf jeden Fall für die gewohnt schnell und umfängliche Hilfe.

Beste Grüße,

Step

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×