Jump to content
Semajsa

Plugin funktioniert nicht

Recommended Posts

Hey,

in der Konsole kommt folgende Fehlermeldung:

[20:49:24 ERROR]: Could not load 'plugins\fly.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: main/Main has been compiled by a more recent version of the Java Runtime (class file version 58.0), this version of the Java Runtime only recognizes class file versions up to 55.0
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.reload(CraftServer.java:739) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.Bukkit.reload(Bukkit.java:535) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:641) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchServerCommand(CraftServer.java:627) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.DedicatedServer.aO(DedicatedServer.java:412) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:375) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at java.base/java.lang.Thread.run(Thread.java:834) [?:?]
Caused by: java.lang.UnsupportedClassVersionError: main/Main has been compiled by a more recent version of the Java Runtime (class file version 58.0), this version of the Java Runtime only recognizes class file versions up to 55.0
        at java.base/java.lang.ClassLoader.defineClass1(Native Method) ~[?:?]
        at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1016) ~[?:?]
        at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174) ~[?:?]
        at java.base/java.net.URLClassLoader.defineClass(URLClassLoader.java:550) ~[?:?]
        at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:458) ~[?:?]
        at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:452) ~[?:?]
        at java.base/java.security.AccessController.doPrivileged(Native Method) ~[?:?]
        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:451) ~[?:?]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588) ~[?:?]
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) ~[?:?]
        at java.base/java.lang.Class.forName0(Native Method) ~[?:?]
        at java.base/java.lang.Class.forName(Class.java:398) ~[?:?]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[server2.jar.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[server2.jar.jar:git-Spigot-db6de12-18fbb24]
        ... 14 more
[20:49:24 INFO]: Server permissions file permissions.yml is empty, ignoring it
[20:49:24 INFO]: CONSOLE: Reload complete.

ich hoffe jemand kann mir helfen. 

LG

Share this post


Link to post
Share on other sites

Das fly plugin ist nicht kompatibel mit der server version

Share this post


Link to post
Share on other sites
vor 2 Minuten schrieb Bedrock:

Das fly plugin ist nicht kompatibel mit der server version

Und wie soll ich das denn fixen?

Share this post


Link to post
Share on other sites

Ka, wo das fly plugin her ist - es muss aber mit java 8 compiliert werden - aktuell ist es java 11 oder 12 oder so

Share this post


Link to post
Share on other sites
vor 19 Minuten schrieb Bedrock:

Ka, wo das fly plugin her ist - es muss aber mit java 8 compiliert werden - aktuell ist es java 11 oder 12 oder so

hm, ja aber das Problem ist, dass ich mit Eclipse programmiere, und ich um Eclipse zu starten die Version 11 oder höher brauche.

Share this post


Link to post
Share on other sites

soweit ich weiß spielt es keine rolle welche version man von eclipse nimmt - man müsste da eigentlich java 8 separat einbinden können

Beim kompilieren kann man dann die java Version auswählen 

Share this post


Link to post
Share on other sites
vor 51 Minuten schrieb Bedrock:

soweit ich weiß spielt es keine rolle welche version man von eclipse nimmt - man müsste da eigentlich java 8 separat einbinden können

Beim kompilieren kann man dann die java Version auswählen 

Aber ich kann Eclipse nicht starten weil sie Java 11 oder höher benötigt. 

Share this post


Link to post
Share on other sites

So tief bin ich in der Eclipse Programmierung aktuell nicht drin 

technisch muss es aber möglich sein, eclipse mit der 11 zu starten, aber die 8 einzubinden 

Andererseits wurde es in den entsprechenden Foren zu viel Feedback deswegen kommen

Schau mal nach Guides bzw tutorials wie man eine ältere java Version einbindet - bin zurzeit am Handy und kann es selbst nich prüfen 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...
B