Jump to content
Bauju

Minecraft Vanilla Server (1.16.2) laggt

Recommended Posts

Hallo liebe Minecraft-Forum-User,

Ich hoste zu Hause einen Minecraft Vanilla Server für ein paar Freunde. Aktuell spielen wir dort nur zu 2., jedoch haben wir sobald ein 2. Spieler on kommt direkt Probleme mit Lags.

 Solche Lags sind jedoch nicht konstant, aber sie tauchen immer öfters auf. Ich vermute aktuell, dass es am Netz liegt, aber weil ich mir noch nicht wirklich Sicher bin, wollte ich hier mal nach Rat fragen.

Der Minecraft-Server läuft unter Linux (Ubuntu) auf einer Virtuellen Maschine eines Servers und wir haben ihm 4 Kerne (2,5 GHz) und 8 GB RAM zugewiesen und wenn ich das Richtig sehe / verstehe scheint die Hardware auch nicht ausgelastet zu sein.

gelegentlich wird einer von uns beiden gekickt und wir bekommen dann die Fehlermeldung:

Verbindung unterbrochen

Internal Exception: io.netty.channel.unix.Errors$NativeIoException: syscall:read(..) failed: Die Verbindung wurde vom Kommunikationspartner zurückgesetzt

Als es einmal stärker gelaggt hat, wurde in der Konsole eine Fehlermeldung ausgegeben. Wenn sie wieder auftaucht, hänge ich ein Screenshot davon hier an. Eigentlich hatte ich bereits ein Screenshot davon gemacht, der ist aber irgendwie nicht da 😕

Wird man aus den Infos schlau? :,D

Wenn ja, kann es wirklich an dem Netz liegen oder ist es doch ein Problem an der Hardware? Jedoch heißt es laut folgender Seite, dass für 1-2 Spieler schon ein Pentium 4 mit 2 GHz reicht

https://minecraft.gamepedia.com/Server/Requirements/Dedicated

Ich hoffe man kann mir helfen und danke im Voraus :)

LG, Julian / Bauju

Share this post


Link to post
Share on other sites

Ich denke mal, es wird an der Leistung des Prozessors liegen.

Was halt auf die Leistung geht, ist die render-distance, die man in der server.properties einstellen kann (7 oder 8 wäre in dem Fall passend) und das mob-spawning.

 

Anbieten würde es sich, wenn ihr z. B. auf Spigot wechselt. Dort gibt es ua. den /timings-befehl, der auflistet, was lags verursacht.

Auch gibt es mehr Einstellungsmöglichkeiten bez. mob-spawning.

 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Am 20.10.2020 um 08:30 schrieb Bedrock:

Ich denke mal, es wird an der Leistung des Prozessors liegen.

Was halt auf die Leistung geht, ist die render-distance, die man in der server.properties einstellen kann (7 oder 8 wäre in dem Fall passend) und das mob-spawning.

 

Anbieten würde es sich, wenn ihr z. B. auf Spigot wechselt. Dort gibt es ua. den /timings-befehl, der auflistet, was lags verursacht.

Auch gibt es mehr Einstellungsmöglichkeiten bez. mob-spawning.

 

 

 

Vielen Dank!

Wir haben den Server nun mit Spigot am laufen und es läuft einwandfrei! (zumindest zu 2. :) )

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...
B