Jump to content

Hast du schon das Minecraftforum.de-Gütesiegel gesehen? Hier kommst du dorthin!

cool_brick24

Minecraft Plugin.yml funktioniert nicht.

Empfohlene Beiträge

Hallo liebe Leser,

ich programmiere derzeit ein Plugin für einen kleinen Server. Doch meine Plugin.yml funktioniert nicht. Der Fehlercode ist folgender:
 

[23:51:06] [Server thread/ERROR]: Could not load 'plugins\MistoryCity.jar' in folder 'plugins'
org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
	at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:160) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:296) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.reload(CraftServer.java:720) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.Bukkit.reload(Bukkit.java:534) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:621) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchServerCommand(CraftServer.java:607) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.DedicatedServer.aP(DedicatedServer.java:407) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:371) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:650) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:554) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at java.lang.Thread.run(Unknown Source) [?:1.8.0_131]
Caused by: org.yaml.snakeyaml.error.YAMLException: java.nio.charset.MalformedInputException: Input length = 1
	at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:254) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:58) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.Yaml.load(Yaml.java:436) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:226) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:155) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	... 13 more
Caused by: java.nio.charset.MalformedInputException: Input length = 1
	at java.nio.charset.CoderResult.throwException(Unknown Source) ~[?:1.8.0_131]
	at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_131]
	at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_131]
	at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_131]
	at org.yaml.snakeyaml.reader.UnicodeReader.read(UnicodeReader.java:125) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:223) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:58) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.Yaml.load(Yaml.java:436) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:226) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:155) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	... 13 more
[23:51:06] [Server thread/ERROR]: Could not load 'plugins\MistoryMoney.jar' in folder 'plugins'
org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
	at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:150) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:296) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.reload(CraftServer.java:720) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.Bukkit.reload(Bukkit.java:534) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:621) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchServerCommand(CraftServer.java:607) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.DedicatedServer.aP(DedicatedServer.java:407) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:371) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:650) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:554) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at java.lang.Thread.run(Unknown Source) [?:1.8.0_131]
Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
	... 14 more

Meine Plugin.yml ist hier zu finden:

https://pastebin.com/4NujA0sK

Ich hoffe ihr könnt mir weiterhelfen. Ich habe schon oft versucht, mit den Zeilen Abstand rum zu probieren.
 

Mfg:

cool_brick24

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Guten Tag, 

die plugin.yml sieht gut aus. Ist diese aber in deiner IDE im richtigen Ordner und wir mit in die jar an die richtige Stelle gepackt?

Die Fehlermeldung betrifft btw 2 Plugins

 

Freundliche Grüße

BloodSKreaper

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Guten Morgen!

Danke erstmal für deine Antwort. 
Meine Plugin.yml befindet sich in dem Ordner "src" so hatte ich es immer bisher gemacht.

 

Liebe Grüße

cool_brick24

aka.

kühler_Ziegel24

T

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Versuch das ganze bitte einmal ohne /reload. /reload aufzurufen, nachdem das Plugin geändert wurde, kann zu sehr seltsamen Fehlern führen.

Sende uns bitte die Log, wenn der Server komplett neu startet.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hey, hier ist mein Log, mit dem Serverneustart!

[16:06:33] [Server thread/ERROR]: Could not load 'plugins\MistoryCity.jar' in folder 'plugins'
org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
	at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:160) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:296) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:188) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:521) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at java.lang.Thread.run(Unknown Source) [?:1.8.0_131]
Caused by: org.yaml.snakeyaml.error.YAMLException: java.nio.charset.MalformedInputException: Input length = 1
	at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:254) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:58) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.Yaml.load(Yaml.java:436) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:226) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:155) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	... 5 more
Caused by: java.nio.charset.MalformedInputException: Input length = 1
	at java.nio.charset.CoderResult.throwException(Unknown Source) ~[?:1.8.0_131]
	at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_131]
	at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_131]
	at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_131]
	at org.yaml.snakeyaml.reader.UnicodeReader.read(UnicodeReader.java:125) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:223) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:58) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.yaml.snakeyaml.Yaml.load(Yaml.java:436) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:226) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:155) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	... 5 more

tut mir leid, dass es länger gedauert hatte, ich war ja in den Ferien :D

Mfg

Ari

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kannst du deine plugin.yml mal als Datei hier hochladen? Also unten rechts "Andere Medien einfügen" => "Existierenden Dateianhang hinzufügen"

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich kann die Datei nicht einfügen, deswegen mach ich das als Code-Tag. Wieso kann ich die nicht einfügen: Da steht: You dont have any existing attachments. Plugin.yml:
 

name: MistoryCityPlugin
version: 1.0
author: cool_brick24
main: de.coolbrick.main.Main
commands:
   ts:
    description: Zeigt dir die TS Ip an
    usage: /<command>
   teamspeak:
    description: Zeigt dir dei TS Ip an
    usage: /<command>
   gm1:
    description: Gibt dir den Gamemode kreativ
    usage: /<command>
   gm0:
    description: Gibt dir den Gamemode überleben
    usage: /<command>
   gm3:
    description: Gibt dir den Gamemode Zuschauer
    usage: /<command>
   hilfe:
     description: Zeigt dir die Übersicht aller Commands dieses Plugin an
     usage: /<command>
   chatclear:
     description: Leert den Chat
     usage: /<command>
   clearchat:
     description: Leert den Chat
     usage: /<command>
   cc:
     description: Leert den Chat
     usage: /<command>
   bc:
     description: Zeigt eine Broadcastmessage an
     usage: /<command>
   broadcast:
     description: Zeigt eine Broadcastmessage an
     usage: /<command>
    

Mfg
Ari

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

es wäre halt leider besser gewesen, wenn die Datei angehängt gewesen wäre, da man so nicht nachvollziehen kann, ob vielleicht ein Charset Fehler vorliegt oder irgendwo ein ungültiges Zeichen vorhanden ist. Da ist das Original halt wichtig.

Es kann eben passieren, wenn das Charset der Datei ungünstig ist also z.B. kein UTF8, dann können Fehler auftreten, oder halt wenn bei der Formatierung irgendwo ein TAB anstatt Leerzeichen verwendet wurden.

Es gibt Online YAML-Validatoren, im Notfall da mal probieren und die Datei hochladen, die meckern dann auch ganz schnell, wenn wo etwas nicht stimmt.

 

-Yuki

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Sorry, ich hab mich vertan. Du musst unterhalb vom Texteditor auf "Wähle die Dateien hier aus" drücken.

Geht's jetzt, oder immer noch nicht?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Es funktioniert mit den Dateien. Ich hatte es in einen YAML Validator durchgeschleust, und dieser erzähl mir, die YAML sei gültig...
Ich hoffe auf weiteren Antworten
MFG 
Ari

plugin.yml

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

also das Problem ist ein entweder / oder Problem. ;)

1. Entweder: du entfernst die Umlaute aus der Datei, also "überleben" und "Übersicht"

2. Oder: du speicherst die Datei als UTF8 anstatt ANSI1252

Habe dir die Datei mal als UTF8 angehängt.

 

-Yuki

plugin.yml

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Danke! Es funktioniert einwandfrei, ich hab die Umlaute in "ue" geändert. Vielen Dank an alle Kommentar schreiber! Eine kleine Sache noch: Bei mir funktioniert zwar das Plugin, aber beim Serverstart kommt ein Error: 

[11:34:51] [Server thread/ERROR]: Error occurred while enabling MistoryCityPlugin v1.0 (Is it up to date?)
java.lang.IllegalArgumentException: Plugin already initialized!
	at org.bukkit.plugin.java.PluginClassLoader.initialize(PluginClassLoader.java:98) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:60) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at de.coolbrick.main.InventoryListener.<init>(InventoryListener.java:11) ~[?:?]
	at de.coolbrick.main.Main.onEnable(Main.java:51) ~[?:?]
	at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:329) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:401) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:360) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:321) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:411) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:372) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:327) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:248) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:521) [craftbukkit.jar:git-Bukkit-9a1fc1e]
	at java.lang.Thread.run(Unknown Source) [?:1.8.0_131]
Caused by: java.lang.IllegalStateException: Initial initialization
	at org.bukkit.plugin.java.PluginClassLoader.initialize(PluginClassLoader.java:101) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:60) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at de.coolbrick.main.Main.<init>(Main.java:15) ~[?:?]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_131]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_131]
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_131]
	at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.8.0_131]
	at java.lang.Class.newInstance(Unknown Source) ~[?:1.8.0_131]
	at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:52) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:325) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:248) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:296) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]
	at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:188) ~[craftbukkit.jar:git-Bukkit-9a1fc1e]

Plugin wurde angeblich schon initsialisiert. 
Ich habe über diesen Fehler keine Kentnisse!
MFG
Ari

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Funktioniert alles Supi!
Danke für alle Antworten und alle Schreiberlinge!
MFG
Ari

PS: Soll ich das Thema schließen, oder wie funktioniert das hier :D? Danke für die Antwort im Voraus

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×