Jump to content

Flashmind

User
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Noch unbekannt

About Flashmind

  • Rank
    Neuling

Profil Information

  • Geschlecht
    Männlich
  • Ort
    Bremen
  • Hobbys
    Technik

Minecraft Information

  • Minecraft
    Flashmind
  1. Zu dem wegen AuthMe und Whitelist, man kann entweder oder Verwenden, aber jedes der beiden Systeme hat Lücken und wenn man sich mit der Serversicherheit eingehends auseinander setzt, dann sieht man, das genau die Lücken im Whitelist mit AuthMe geschlossen werden und vice versa ! Wer bei mir einloggt wird erst von mir Regestriert und auf OPt "1" gesetzt, das heisst ich als OPt "4" Admin vergebe Passwort und habe die Berechtigung Whitelisten zu Verwalten, das kann der Benutzer nicht. Somit wenn jemand bei mir Joind Prüft bevor er überhaupt meine Serverwelt sieht und zum Login aufgefordert wird, das heisst ein Hackerer kommt durch die Whitelist-stoppung garnicht bis zum AuthMe login kommando, kann also auch nicht selbst oder mit einem BOT mit dem Passworthack beginnen, weil da ja dann schon steht bei der Weiterleitung an meinen Serverzugang, das er nicht per Whitelist berechtigt ist ! erst wenn dann die Whitelist den User bis zum Server führt das Logonbild zeigt wird der User begrüsst und aufgefordert sein Passwot/Login einzugeben, dafür hat der User genau 20 sec Zeit ! Ist das Passwort richtig ist er in meiner Welt, wenn nicht wird die Verbindung von meinem Server gekappt und ist auch nicht mehr sichtbar. dann muss der User zurück den Launcher neu Starten um wieder an die Serverliste und Whitelist Prüfung zu kommen !!!!! Sicherer kann man es nicht mehr machen ! 😉😉 Das muss man natürlich bei einem Offiziellen Server mit Mojang Login nicht machen da hat man die Sicherheit vom Mojamg Launcher, aber bei einem Offenen/Gerackten Server schon !
  2. Also ich scheine es gefunden zu haben !? Ich mache noch weitere Test's aber es war Tatsächlich ein Playerdata-Cache !!!!!! Ich habe weiter gegraben (im wahrsten Sinne des Wortes) und habe einen sich gleich nach dem einloggen im server (nachdem der Login vollzogen war und dann die Kettenschuhe sich zuschalten) ändernden Wert gefunden (habe einen Debuglogger im Windows mitlaufen lassen). Der Dateieintrag wurde sofort immer im eigentlichen Minecraftserver unter dem Ordner "World" - playerdata ordner als sich änderndes .dat File gemacht (deswegen war auch mein Versuch mit dem Backup nutzlos weil dieser Eintrag sich sofort nach dem enloggen immer ändert. Als Identifikation wird immer die Player UUID Verarbeitet. Ich habe also diesen eintrag mit meiner Betreffenden UUID gelöscht, den Clienten auf meiner Seite gestartet und wieder neu gejoint und wie von Geisterhand sind die Kettenschuhe nicht mehr da, der Eintrag mit meiner UUID wurde aber neu wieder in dem Betreffenden Ordner "Minecraftserver/world/playerdata/xxxxxxxxxxxxxxx.dat" wieder neu wohl vom server Angelegt. Es scheint also auch nach mehrmaligem Aus-und wieder Einloggen der Fehler nicht mehr wieder aufzutauchen ! Wenn dies der Fall sein sollte, dann weiss ich jetzt wie ich das wieder hinbekomme und dann werde ich nochmals das gleiche mit SkinRestorer machen um zu schauen ob dann der Fehler wiederkommt, denn dann ist es definitif ein grosser BUG von SkinRestorer ! Ich Melde mich und werde aufjedenfall berichten, denn vielleicht hilft das auch anderen und ich weiss so hat es mir der SR Support geschrieben gibt es probleme mit solchen Geistererscheinungen wohl auch bei einigen anderen !
  3. AuthMe ! Aber ich habe mal weiter Probiert und die Idee von Dir mit der UUID aufgenommen und das gemischt mit meiner letzten Idee, das es viellicht garnicht von der Serverseite kommt, sondern von der clienten seite ! Ich habe mal einen neuen Benutzer/User als Kitty09 angelegt von der Clientenseite aus, dann das ganze Prozedere wie auch sonst üblich mit Serverseitges eintragen in die Whitelist und danach die Registratur mit Passwort unter AuthMe.... Und siehe da wenn ich von einem LapTop clienten mit Kitty09 auf meinem Server Joine Voala keine Kettenboots an dem Skin mehr auch nach dem Login von Kitty09 nicht ! Jetzt wenn ich von einem anderen Computer Clienten dann dazu Joine wie sonst auch immer mit meinem Namen und Passwort Bumm ich habe die Kettenschuhe gleich wieder an und das beste zum schluss stehe ich als Flashfigur direkt der Kitty 09 gegenüber, sehe ich als Flash Kitty09 ganz normal ohne Kettenschuhe und wenn ich von der Kitty09 Seite auf mich schaue habe ich die Kettenschuhe an ! Das heisst es scheint ob alle alten UUID's zestrört sind, weil alle neuen gehen einwandfrei. Wir kommen der Sache wohl schon näher aber ich weiss immer noch nichtg genau wo ich jetzt ansetzten soll, denn ich kann ja nicht (ist zwar einfacher als das ganze System neu Aufzusetzten) neue Namen eingeben und meine Familie alle neu Regestrieren, dann stimmen ja auch die Opt's alle nicht mehr und und und.........
  4. Nein im Inventar ist garnichts dergleichen, sowiso die Version 1.8.9 ist schon eine alte Version (2015-2016) da ist das Inventar bei weitem nicht so voll wie bei den neueren Versionen. Da ich ja meinen Aktuellen Minecraftserver komplett gelöscht hatte und mit einem davor Backup wieder auf den Urzustand vor der Testinstalation von SkinRestorer gebracht habe (also eine saubere Version ohne irgendwelche SkinRestorer Plugin Sachen) dürfte diese Vermutung nicht zum tragen kommen. Ich gehe mal davon aus, das irgendwas im Windows etc. hinterlegt wurde welches er nach dem Login von irgendwoher herholt und dann die Änderung vornimmt ! Ich glaube auch das mir wohl keiner helfen kann, das einzige was mir vielleicht noch bleibt ist den Server & Spigot komplett neu aufzusetzten und die ganze Arbeit von Jahren ist einfach weg, trotz der vollen Täglichen Backups, denn die helfen hier nicht weiter und aus der Gefahr, das noch irgendwoanders auf dem Server als cache nochwas hinterlegt ist welches ich nicht weiss bleibt mir halt nur das von NULL neu aufgsetzen das gilt fann auch für das Windows Betriebssystem 😡😭 Tja wie wie sagt man so schön "Don't touch a running System" hätte ich mal diesen blöden versuch nicht gemacht, denn definitiv hat mir das SkinRestorer Plugin den Schuss gegeben !
  5. Danke für Dein reply, guter Idee Ansatz, doch erübrigt sich das, weil ich den Aktuellen MinecraftServerOrdner komplett vom System gelöscht habe (also auch alle Datein, Plugins, Configdateien, UUID-whitelist, Authme etc), dann habe ich aus einem vollen kompletten Backup eben dieser Serverdatei (die wird bei mir jede Nacht einmal gesichert) vom: 05.09.2019 zurückgeholt und dann den Server wieder gestartet. Die Änderung mit dem einfügen von SkinRestorer war ja am Montag den: 09.09.2019 also kann ich ja sicher sein, das ich eigentlich den Server mit allem was dazugehört auf den Originalen Stand habe wie vor der Änderung ! Ich habe einfach ein gefühl als ob irgendwo noch sonst irgendwelche Daten in Irgendeinem Windows oder Java oder %AppData% Cache ist !? Oder kann das von den Clients kommen, das sobald sich der Client mit dem Server Verbindet dann irgendwie etwas mitsendet, denn ich habe gesehen das es eine Server.dat auf jedem im Minecraft Launcher gibt, die immer nach dem einloggen wohl geändert wird. Übrigens wenn ich den UUID im spigot Ordner löschen würde, dann kann ich ja nicht mehr auf dem Server Joinen, aber wie gesagt durch das Backup ist auch der letzte Zeitstempel dieser Dateien auf Stand: 05.09.2019 21:33 das heisst ja auch vor der SkinRestorer Änderung !
  6. Hallo, kann mir einer mit einem komischen Problem helfen !? Ich habe seit 2016 einen eigenen Privaten Spigot Server für meine Familie laufen auch sehr erfolgreich mit mods und Plugins bestückt sehr wartungsarm, musste eigentlich nie etwas ändern und er lief perfekt ! Wir loggen immer mit der Minecraft Version 1.8.9 ein. Ich hatte weil ich jetzt etwas Zeit hatte mal ein Plugin SkinRestorer ausprobiert, welches ich aber dann wieder entfernt hatte, weil ich es eigentlich nicht brauche. Dies schien ein Fehler gewesen zu sein, denn seitdem habe ich ein komisches Phänomen welches ich nicht mehr wegbekomme, obwohl ich sogar ein volles Serverbackup zurückgeholt habe welches mein System jede Nacht macht (der Restore den ich zurückgeholt habe war einer vor der SkinRestorer Änderung, somit sollte der Server doch eiegntlich wieder so laufen wie vorher - doch weit gefehlt). Also das Symtom welches seitdem auftritt ist wenn ich auf den Server vom launcher zugreife (bevor ich den Login meines Servers eingegeben habe) kann man den skin normal sehen, jedoch nach dem Login haben alle skins Plötzlich durchsichtige kleine grau quadratische Schuhe an, egal welcher skin egal welcher User, alles andere Funktioniert wie vorher auch nur das eben die Skins diese komischen Quadrate anhaben durch welche man aber die normalen Schuhe sehen kann. Dieses habe ich nicht wenn ich zbs. über den Launcher Lokal auf eine Generierte Welt gehe, da ist mein Skin einwandfrei. Was mich halt besonders Wundert ist ja der Zustand, das man auf dem Einlogbild vom Server erst den Skin sauber sieht und nachdem Einlogvorgang sofort die Schuhe angezogen werden. Irgendwo muss der Spigotserver in Windows oder Java etwas hinterlegt haben, denn wenn ich ein komplettes Backup zurückhole, kann es nichts mit dem Spigot Ordner mehr zu tun haben ! Habe auch schon %AppData% durchgeforstet (davon habe ich leider kein Backup) und auch schonmal in der JAVA Anwedung geschaut, kann aber nichts finden Hat noch jemand eine Idee !? P.S. Erste Bild vor dem Login / Zweite Bild nach dem Login
×
×
  • Create New...